Algorithm
problem Link : https://onlinejudge.org/index.php?option=onlinejudge&Itemid=8&page=show_problem&problem=1927
“A new internet watchdog is creating a stir in Springfield. Mr. X, if that is his real name, has come up with a sensational scoop.” Kent Brockman There are n SMTP servers connected by network cables. Each of the m cables connects two computers and has a certain latency measured in milliseconds required to send an email message. What is the shortest time required to send a message from server S to server T along a sequence of cables? Assume that there is no delay incurred at any of the servers. Input The first line of input gives the number of cases, N. N test cases follow. Each one starts with a line containing n (2 ≤ n ≤ 20000), m (0 ≤ m ≤ 50000), S (0 ≤ S < n) and T (0 ≤ T < n). S ΜΈ= T. The next m lines will each contain 3 integers: 2 different servers (in the range [0, n − 1]) that are connected by a bidirectional cable and the latency, w, along this cable (0 ≤ w ≤ 10000). Output For each test case, output the line ‘Case #x:’ followed by the number of milliseconds required to send a message from S to T. Print ‘unreachable’ if there is no route from S to T. Sample Input 3 2 1 0 1 0 1 100 3 3 2 0 0 1 100 0 2 200 1 2 50 2 0 0 1
Sample Output Case #1: 100 Case #2: 150 Case #3: unreachable
Code Examples
#1 Code Example with C Programming
Code -
C Programming
#include <bits/stdc++.h>
using namespace std;
int main()
{
int t,n,m,s,e,a,b,w,tc=1;
scanf("%d",&t);
while(t--){
scanf("%d %d %d %d",&n,&m,&s,&e);
vector < vector<pair<int,int>>> graph(n);
vector<int> dist(n,1e7);
for(int i=0;i < m;i++){
scanf("%d %d %d",&a,&b,&w);
graph[a].push_back({b,w});
graph[b].push_back({a,w});
}
// dijkstra
dist[s] = 0;
priority_queue < pair<int,int>,vector<pair<int,int>>,greater < pair<int,int>>> pq;
pq.push({0,s});
while(!pq.empty()){
int cost, cur;
tie(cost,cur) = pq.top(); pq.pop();
if(cost > dist[cur]) continue;
for(auto& neigh : graph[cur]){
int nextCost = cost + neigh.second;
if(nextCost < dist[neigh.first]){
pq.push({nextCost,neigh.first}>;
dist[neigh.first] = nextCost;
}
}
}
if(dist[e] >= 1e7) printf("Case #%d: unreachable\n",tc++);
else printf("Case #%d: %d\n",tc++,dist[e]);
}
}
Copy The Code &
Try With Live Editor
Input
2 1 0 1
0 1 100
3 3 2 0
0 1 100
0 2 200
1 2 50
2 0 0 1
Output
Case #2: 150
Case #3: unreachable
Demonstration
UVA Online Judge solutio - 10986-Sending email - UVA Online Judge solution in C,C++,java