Algorithm


problem Link : https://onlinejudge.org/index.php?option=onlinejudge&Itemid=8&page=show_problem&problem=1917

It is easy to see that for every fraction in the form 1 k (k > 0), we can always find two positive integers x and y, x ≥ y, such that: 1 k = 1 x + 1 y Now our question is: can you write a program that counts how many such pairs of x and y there are for any given k? Input Input contains no more than 100 lines, each giving a value of k (0 < k ≤ 10000). Output For each k, output the number of corresponding (x, y) pairs, followed by a sorted list of the values of x and y, as shown in the sample output.

Sample Input 2 12

Sample Output 2 1/2 = 1/6 + 1/3 1/2 = 1/4 + 1/4 8 1/12 = 1/156 + 1/13 1/12 = 1/84 + 1/14 1/12 = 1/60 + 1/15 1/12 = 1/48 + 1/16 1/12 = 1/36 + 1/18 1/12 = 1/30 + 1/20 1/12 = 1/28 + 1/21 1/12 = 1/24 + 1/24

Code Examples

#1 Code Example with C Programming

Code - C Programming

#include <bits/stdc++.h>
using namespace std;
// find x,y such that x*y = k*y+k*x
// y = (x*k)/(x-k), if check x*k with mod of x-k, then there exist a y

int main() {
    int k;
    while(scanf("%d",&k) != EOF){
        vector < pair<int,int>> res;
        // check until 2*k, the highest possible val for x or y
        for(int x=k+1;x < =2*k;x++){
            if(((x*k) % (x-k)) != 0) continue;
            int y = (x*k)/(x-k);
            res.push_back({y,x});
        }
        cout << res.size() << endl;
        for(auto& p : res){
            printf("1/%d = 1/%d + 1/%d\n",k,p.first,p.second);
        }
    }
}

Copy The Code & Try With Live Editor

Input

x
+
cmd
2
12

Output

x
+
cmd
2
1/2 = 1/6 + 1/3
1/2 = 1/4 + 1/4
8
1/12 = 1/156 + 1/13
1/12 = 1/84 + 1/14
1/12 = 1/60 + 1/15
1/12 = 1/48 + 1/16
1/12 = 1/36 + 1/18
1/12 = 1/30 + 1/20
1/12 = 1/28 + 1/21
1/12 = 1/24 + 1/24
Advertisements

Demonstration


UVA Online Judge solution - 10976-Fractions Again?! - UVA Online Judge solution in C,C++,java

Previous
UVA Online Judge solution - 10973-Triangle Counting - UVA Online Judge solution in C,C++,java
Next
UVA Online Judge solution - 1098-Robots on Ice - UVA Online Judge solution in C,C++,java