Algorithm


Problem link : https://onlinejudge.org/index.php?option=onlinejudge&Itemid=8&page=show_problem&problem=982 

The world-known gangster Vito Deadstone is moving to New York. He has a very big family there, all of them living in Lamafia Avenue. Since he will visit all his relatives very often, he is trying to find a house close to them. Vito wants to minimize the total distance to all of them and has blackmailed you to write a program that solves his problem. Input The input consists of several test cases. The first line contains the number of test cases. For each test case you will be given the integer number of relatives r (0 < r < 500) and the street numbers (also integers) s1, s2, . . . , si , . . . , sr where they live (0 < si < 30000 ). Note that several relatives could live in the same street number. Output For each test case your program must write the minimal sum of distances from the optimal Vito’s house to each one of his relatives. The distance between two street numbers si and sj is dij = |si − sj |.

Sample Input 2 2 2 4 3 2 4 6

Sample Output 2 4

Code Examples

#1 Code Example with C Programming

Code - C Programming

 #include <bits/stdc++.h>
using namespace std;

int main() {
    int t,n,v;
    cin >> t;
    while(t--){
        cin >> n;
        vector<int> neigh;
        int sum = 0;
        while(n--){
            cin >> v;
            neigh.push_back(v);
        }
        sort(neigh.begin(),neigh.end());
        int median = neigh[neigh.size()/2];

        for(auto& v : neigh) sum += abs(v-median);

        cout << sum << endl;
    }
}
Copy The Code & Try With Live Editor

Input

x
+
cmd
2
2 2 4
3 2 4 6

Output

x
+
cmd
2
4
Advertisements

Demonstration


UVA Online Judge solution - 10041 - Vito's Family - UVA Online Judge solution in C,C++,Java

Previous
UVA Online Judge solution - 10036 - Divisibility - UVA Online Judge solution in C,C++,Java
Next
UVA Online Judge solution - 10047 - The Monocycle - UVA Online Judge solution in C,C++,Java