Algorithm


problem Link ; https://onlinejudge.org/index.php?option=onlinejudge&Itemid=8&page=show_problem&problem=1876 

Given is an ordered deck of n cards numbered 1 to n with card 1 at the top and card n at the bottom. The following operation is performed as long as there are at least two cards in the deck: Throw away the top card and move the card that is now on the top of the deck to the bottom of the deck. Your task is to find the sequence of discarded cards and the last, remaining card. Input Each line of input (except the last) contains a number n ≤ 50. The last line contains ‘0’ and this line should not be processed. Output For each number from the input produce two lines of output. The first line presents the sequence of discarded cards, the second line reports the last remaining card. No line will have leading or trailing spaces. See the sample for the expected format.

Sample Input 7 19 10 6 0

Sample Output Discarded cards: 1, 3, 5, 7, 4, 2 Remaining card: 6 Discarded cards: 1, 3, 5, 7, 9, 11, 13, 15, 17, 19, 4, 8, 12, 16, 2, 10, 18, 14 Remaining card: 6 Discarded cards: 1, 3, 5, 7, 9, 2, 6, 10, 8 Remaining card: 4 Discarded cards: 1, 3, 5, 2, 6 Remaining card: 4

Code Examples

#1 Code Example with C Programming

Code - C Programming

#include <iostream>
#include <fstream>
#include <sstream>
#include <iomanip>
#include <cmath>
#include <stdio.h>
#include <limits.h>
#include <string.h>
#include <vector>
#include <algorithm>
#include <set>
#include <map>
#include <unordered_map>
#include <unordered_set>
#include <list>
#include <deque>
#include <queue>
#include <stack>
using namespace std;

int main() {
    int n;
    while(cin >> n, n){
        list < int> deck;
        for(int i=n;i>0;i--) deck.push_back(i);
        cout << "Discarded cards:";
        while(deck.size() > 1){
            cout << " " << deck.back();
            deck.pop_back();
            if(deck.size() > 1) cout << ",";
            deck.push_front(deck.back()); deck.pop_back();
        }
        cout << endl << "Remaining card: " << deck.front() << endl;
    }
}

Copy The Code & Try With Live Editor

Input

x
+
cmd
7
19
10
6
0

Output

x
+
cmd
Discarded cards: 1, 3, 5, 7, 4, 2
Remaining card: 6
Discarded cards: 1, 3, 5, 7, 9, 11, 13, 15, 17, 19, 4, 8, 12, 16, 2, 10, 18, 14
Remaining card: 6
Discarded cards: 1, 3, 5, 7, 9, 2, 6, 10, 8
Remaining card: 4
Discarded cards: 1, 3, 5, 2, 6
Remaining card: 4
Advertisements

Demonstration


UVA Online Judge solution - 10935-Throwing cards away I - UVA Online Judge solution in C,C++,java

Previous
UVA Online Judge solution - 10928-My Dear Neighbours - UVA Online Judge solution in C,C++,java
Next
UVA Online Judge solution - 10943-How do you add? - UVA Online Judge solution in C,C++,java