Algorithm


problem Link : https://onlinejudge.org/index.php?option=onlinejudge&Itemid=8&page=show_problem&problem=1704 

Your non-profit organization (iCORE - international Confederation of Revolver Enthusiasts) coordinates a very successful foreign student exchange program. Over the last few years, demand has sky-rocketed and now you need assistance with your task. The program your organization runs works as follows: All candidates are asked for their original location and the location they would like to go to. The program works out only if every student has a suitable exchange partner. In other words, if a student wants to go from A to B, there must be another student who wants to go from B to A. This was an easy task when there were only about 50 candidates, however now there are up to 500000 candidates! Input The input file contains multiple cases. Each test case will consist of a line containing n – the number of candidates (1 ≤ n ≤ 500000), followed by n lines representing the exchange information for each candidate. Each of these lines will contain 2 integers, separated by a single space, representing the candidate’s original location and the candidate’s target location respectively. Locations will be represented by nonnegative integer numbers. You may assume that no candidate will have his or her original location being the same as his or her target location as this would fall into the domestic exchange program. The input is terminated by a case where n = 0; this case should not be processed. Output For each test case, print ‘YES’ on a single line if there is a way for the exchange program to work out, otherwise print ‘NO’.

Sample Input 10 1 2 2 1 3 4 4 3 100 200 200 100 57 2 2 57 1 2 2 1 10 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 0

Sample Output YES NO

Code Examples

#1 Code Example with C Programming

Code - C Programming

#include <bits/stdc++.h>
using namespace std;

int main() {
    int n,a,b;
    while(scanf("%d",&n),n){
        int remaining = n;
        unordered_map < int,unordered_multiset<int>> fromTo;
        for(int i=0;i < n;i++){
            cin >> a >> b;
            if(fromTo[b].count(a)){
                remaining -= 2;
                fromTo[b].erase(fromTo[b].find(a));
            } else {
                fromTo[a].insert(b);
            }
        }
        cout << (remaining == 0 ? "YES" : "NO") << endl;
    }
}
Copy The Code & Try With Live Editor

Input

x
+
cmd
10
1 2
2 1
3 4
4 3
100 200
200 100 2 57
1 2
2 1
10
1 2
3 4
5 6
7 8
9 10
11 12
13 14
15 16
17 18
19 20
0

Output

x
+
cmd
YES
NO
Advertisements

Demonstration


UVA Online Judge solution - 10763-Foreign Exchange - UVA Online Judge solution in C,C++,java

Previous
UVA Online Judge solution - 10759-Dice Throwing - UVA Online Judge solution in C,C++,java
Next
UVA Online Judge solution - 10765-Doves and bombs - UVA Online Judge solution in C,C++,java