Algorithm


problem Link : https://onlinejudge.org/index.php?option=onlinejudge&Itemid=8&page=show_problem&problem=1995 

As you may know from the comic “Asterix and the Chieftain’s Shield”, Gergovia consists of one street, and every inhabitant of the city is a wine salesman. You wonder how this economy works? Simple enough: everyone buys wine from other inhabitants of the city. Every day each inhabitant decides how much wine he wants to buy or sell. Interestingly, demand and supply is always the same, so that each inhabitant gets what he wants. There is one problem, however: Transporting wine from one house to another results in work. Since all wines are equally good, the inhabitants of Gergovia don’t care which persons they are doing trade with, they are only interested in selling or buying a specific amount of wine. They are clever enough to figure out a way of trading so that the overall amount of work needed for transports is minimized. In this problem you are asked to reconstruct the trading during one day in Gergovia. For simplicity we will assume that the houses are built along a straight line with equal distance between adjacent houses. Transporting one bottle of wine from one house to an adjacent house results in one unit of work. Input The input consists of several test cases. Each test case starts with the number of inhabitants n (2 ≤ n ≤ 100000). The following line contains n integers ai (−1000 ≤ ai ≤ 1000). If ai ≥ 0, it means that the inhabitant living in the i-th house wants to buy ai bottles of wine, otherwise if ai < 0, he wants to sell −ai bottles of wine. You may assume that the numbers ai sum up to 0. The last test case is followed by a line containing ‘0’. Output For each test case print the minimum amount of work units needed so that every inhabitant has his demand fulfilled. You may assume that this number fits into a signed 64-bit integer (in C/C++ you can use the data type “long long”, in JAVA the data type “long”).

Sample Input 5 5 -4 1 -3 1 6 -1000 -1000 -1000 1000 1000 1000 0

Sample Output 9 900

Code Examples

#1 Code Example with C Programming

Code - C Programming

 #include <bits/stdc++.h>
using namespace std;

int main()
{
    int n,v;
    while(scanf("%d",&n),n){
        long long cur = 0, res = 0;
        for(int i=0;i < n;i++){
            cin >> v;
            cur += v;
            // positive indicate I want wine to be moved here
            // negative, wines have to be shifted from here
            // so either way, add them as part of result
            res += abs(cur);
        }
        printf("%lld\n",res);
    }
}
 
Copy The Code & Try With Live Editor

Input

x
+
cmd
5
5 -4 1 -3 1
6
-1000 -1000 -1000 1000 1000 1000
0

Output

x
+
cmd
9
9000
Advertisements

Demonstration


UVA Online Judge solution -11054-Wine trading in Gergovia -  UVA Online Judge solution in C,C++,java

Previous
UVA Online Judge solution - 11040-Add_bricks_in_the_wall - UVA Online Judge solution in C,C++,java
Next
UVA Online Judge solution - 11057-Exact Sum - UVA Online Judge solution in C,C++,java