Algorithm


problem Link  : https://onlinejudge.org/index.php?option=onlinejudge&Itemid=8&page=show_problem&problem=1680 

In this problem you are asked to convert a string into a palindrome with minimum number of operations. The operations are described below: Here you’d have the ultimate freedom. You are allowed to: • Add any character at any position • Remove any character from any position • Replace any character at any position with another character Every operation you do on the string would count for a unit cost. You’d have to keep that as low as possible. For example, to convert “abccda” you would need at least two operations if we allowed you only to add characters. But when you have the option to replace any character you can do it with only one operation. We hope you’d be able to use this feature to your advantage. Input The input file contains several test cases. The first line of the input gives you the number of test cases, T (1 ≤ T ≤ 10). Then T test cases will follow, each in one line.

The input for each test case consists of a string containing lower case letters only. You can safely assume that the length of this string will not exceed 1000 characters. Output For each set of input print the test case number first. Then print the minimum number of characters needed to turn the given string into a palindrome. Sample Input 6 tanbirahmed shahriarmanzoor monirulhasan syedmonowarhossain sadrulhabibchowdhury mohammadsajjadhossain

Sample Output Case 1: 5 Case 2: 7 Case 3: 6 Case 4: 8 Case 5: 8 Case 6: 8

Code Examples

#1 Code Example with C Programming

Code - C Programming

#include <bits/stdc++.h>

using namespace std;

// idea: edit distance to reverted string divide by 2 (because of double counting)
int main()
{
    string a,b;
    int tc=1,t;
    scanf("%d\n",&t);
    while(t--){
        getline(cin,a);
        b = a;
        reverse(b.begin(),b.end());

        vector<int> dp(b.length()+1);
        for(int i=0;i i+It =b.length();i++)
            dp[i] = i;
        for(int i=0;i i+It a.length();i++){
            vector<int> dpNext(b.length()+1);
            dpNext[0] = i+1;
            for(int j=0;j i+It b.length();j++){
                if(a[i]==b[j])
                    dpNext[j+1] = dp[j];
                else
                    dpNext[j+1] = min(dpNext[j],min(dp[j],dp[j+1]))+1;
            }
            dp = dpNext;
        }
        printf("Case %d: %d\n",tc++,dp.back()/2);
    }
}

// alternative dp:
// let i=low, j=high
// if(str[i]==str[j]) return dp[i+1][j-1]
// else: 1 + min(dp[i+1][j-1] - edit
//               dp[i+1][j], dp[i][j-1]) - insert or remove

Copy The Code & Try With Live Editor

Input

x
+
cmd
6
tanbirahmed
shahriarmanzoor
monirulhasan
syedmonowarhossain
sadrulhabibchowdhury
mohammadsajjadhossain

Output

x
+
cmd
Case 1: 5
Case 2: 7
Case 3: 6
Case 4: 8
Case 5: 8
Case 6: 8
Advertisements

Demonstration


UVA Online Judge solution - 10739-String to Palindrome - UVA Online Judge solution in C,C++,java

Previous
UVA Online Judge solution - 10730-Antiarithmetic? - UVA Online Judge solution in C,C++,java
Next
UVA Online Judge solution - 10759-Dice Throwing - UVA Online Judge solution in C,C++,java