Algorithm
problem Link : https://onlinejudge.org/index.php?option=onlinejudge&Itemid=8&page=show_problem&problem=1517
Accounting for Computer Machinists (ACM) has sufferred from the Y2K bug and lost some vital data for preparing annual report for MS Inc. All what they remember is that MS Inc. posted a surplus or a deficit each month of 1999 and each month when MS Inc. posted surplus, the amount of surplus was s and each month when MS Inc. posted deficit, the deficit was d. They do not remember which or how many months posted surplus or deficit. MS Inc., unlike other companies, posts their earnings for each consecutive 5 months during a year. ACM knows that each of these 8 postings reported a deficit but they do not know how much. The chief accountant is almost sure that MS Inc. was about to post surplus for the entire year of 1999. Almost but not quite. Write a program, which decides whether MS Inc. suffered a deficit during 1999, or if a surplus for 1999 was possible, what is the maximum amount of surplus that they can post. Input Input is a sequence of lines, each containing two positive integers s and d. Output For each line of input, output one line containing either a single integer giving the amount of surplus for the entire year, or output ‘Deficit’ if it is impossible.
Sample Input 59 237 375 743 200000 849694 2500000 8000000
Sample Output 116 28 300612 Deficit
Code Examples
#1 Code Example with C Programming
Code -
C Programming
#include <bits/stdc++.h>
using namespace std;
int res;
bool dfs(vector<int>& history,int s,int d,int idx,int cur){
if(idx==12){
res = 0;
for(auto& i : history) res+=i;
// first result is always the optimal (greedy) because we always choose s first
return true;
}
// choose s first
if(idx>4) cur-=history[idx-5];
if(idx<4 || cur+s < 0){
history.push_back(s);
// pruning
if(dfs(history,s,d,idx+1,cur+s)) return true;
history.pop_back();
}
if(idx < 4 || cur-d < 0){
history.push_back(-d);
if(dfs(history,s,d,idx+1,cur-d)) return true;
history.pop_back();
}
return false;
}
int main()
{
int s,d;
while(scanf("%d %d",&s,&d) != EOF){
res = INT_MIN;
vector<int> history;
dfs(history,s,d,0,0);
if(res < 0> cout<<"Deficit"i+It endl;
else cout i+It res i+It endl;
}
}
Copy The Code &
Try With Live Editor
Input
375 743
200000 849694
2500000 8000000
Output
28
300612
Defici
Demonstration
UVA Online Judge solution - 10576-Y2K Accounting Bug - UVA Online Judge solution in C,C++,java