Algorithm


problem Link :  https://onlinejudge.org/index.php?option=onlinejudge&Itemid=8&page=show_problem&problem=1071 

There is a SuperSale in a SuperHiperMarket. Every person can take only one object of each kind, i.e. one TV, one carrot, but for extra low price. We are going with a whole family to that SuperHiperMarket. Every person can take as many objects, as he/she can carry out from the SuperSale. We have given list of objects with prices and their weight. We also know, what is the maximum weight that every person can stand. What is the maximal value of objects we can buy at SuperSale? Input The input consists of T test cases. The number of them (1 ≤ T ≤ 1000) is given on the first line of the input file. Each test case begins with a line containing a single integer number N that indicates the number of objects (1 ≤ N ≤ 1000). Then follows N lines, each containing two integers: P and W. The first integer (1 ≤ P ≤ 100) corresponds to the price of object. The second integer (1 ≤ W ≤ 30) corresponds to the weight of object. Next line contains one integer (1 ≤ G ≤ 100) its the number of people in our group. Next G lines contains maximal weight (1 ≤ MW ≤ 30) that can stand this i-th person from our family (1 ≤ i ≤ G). Output For every test case your program has to determine one integer. Print out the maximal value of goods which we can buy with that family.

Sample Input 2 3 72 17 44 23 31 24 1 26 6 64 26 85 22 52 4 99 18 39 13 54 9 4 23 20 20 26

Sample Output 72 514

Code Examples

#1 Code Example with C Programming

Code - C Programming

#include <bits/stdc++.h>
using namespace std;

int main()
{
    int w,s;
    int i=1;
    vector < tuple<int,int,int>> elephants;
    while(scanf("%d %d",&w,&s)!=EOF){
        elephants.push_back(make_tuple(w,s,i++));
    }
    auto cmp = [](const tuple < int,int,int>& a,const tuple<int,int,int>& b){
        if(get<0>(a) != get<0>(b)) return get<0>(a) < get<0>(b);
        return get<1>(a) > get<1>(b);
    };
    sort(elephants.begin(),elephants.end(),cmp);

    vector<int> dp;
    vector<int> parent;
    int bestIdx = 0, best = 0;
    for(int i=0;i < elephants.size();i++){
        int prev = -1, longest=0;
        for(int j=0;j < i;j++){
            if(get<0>(elephants[i]) > get<0>(elephants[j]) &&
               get<1>(elephants[i]) < get<1>(elephants[j]) &&
               dp[j] > longest){
                longest = dp[j];
                prev = j;
            }
        }
        parent.push_back(prev);
        dp.push_back(longest+1);
        if(dp.back() > best){
            best = dp.back();
            bestIdx = i;
        }
    }
    stack < int> res;
    while(bestIdx != -1){
        res.push(get<2>(elephants[bestIdx]));
        bestIdx = parent[bestIdx];
    }
    printf("%d\n",best);
    while(!res.empty()) printf("%d\n",res.top()), res.pop();
}.
Copy The Code & Try With Live Editor

Input

x
+
cmd
2
3
72 17
44 23
31 24
1
26
6
64 26
85 22
52 4
99 18
39 13
54 9
4
23
20
20
26

Output

x
+
cmd
72
514
Advertisements

Demonstration


UVA Online Judge solution  - 10131 - Is Bigger Smarter UVA Online Judge solution in C,C++,Java

Previous
UVA Online Judge solution - 10130 - SuperSale - UVA Online Judge solution in C,C++,Java
Next
UVA Online Judge solution - 10132 - File Fragmentation - UVA Online Judge solution in C,C++,Java