Algorithm


problem Link : https://onlinejudge.org/index.php?option=onlinejudge&Itemid=8&page=show_problem&problem=1341 

A game show in Britain has a segment where it gives its contestants a sequence of positive numbers and a target number. The contestant must make a mathematical expression using all of the numbers in the sequence and only the operators: +, -, * and /. Each number in the sequence must be used exactly once, but each operator may be used zero to many times. The expression should be read from left to right, without regard for order of operations, to calculate the target number. It is possible that no expression can generate the target number. It is possible that many expressions can generate the target number. There are three restrictions on the composition of the mathematical expression: • the numbers in the expression must appear in the same order as they appear in the input file • Since the target will always be an integer value (a positive number), you are only allowed to use / in the expression when the result will give a remainder of zero. • You are only allowed to use an operator in the expression, if its result after applying that operator is an integer from (-32000 . . . +32000). Input The input file describes multiple test cases. The first line contains the number of test cases n. Each subsequent line contains the number of positive numbers in the sequence p, followed by p positive numbers, followed by the target number. Note that 0 < p ≤ 100. There may be duplicate numbers in the sequence. But all the numbers are less than 32000. Output The output file should contain an expression, including all k numbers and k−1 operators plus the equals sign and the target. Do not include spaces in your expression. Remember that order of operations does not apply here. If there is no expression possible output ‘NO EXPRESSION’ (without the quotes). If more than one expression is possible, any one of them will do.

Sample Input 3 3 5 7 4 3 2 1 1 2000 5 12 2 5 1 2 4

Sample Output 5+7/4=3 NO EXPRESSION 12-2/5*1*2=4

Code Examples

#1 Code Example with C Programming

Code - C Programming

#include <bits/stdc++.h>
using namespace std;

int t,n,target,v;
vector<int> nums;
vector < unordered_set<int>> visited;
vector < char> ops;

bool dfs(int idx,int val){
    if(val > 32000 || val < -32000) return false;
    if(idx == n) return val == target;
    if(visited[idx].count(val)) return false; // already visited return false

    visited[idx].insert(val);
    if(dfs(idx+1,val+nums[idx])){
        ops.push_back('+');
        return true;
    }
    if(dfs(idx+1,val-nums[idx])){
        ops.push_back('-');
        return true;
    }
    if(dfs(idx+1,val*nums[idx])){
        ops.push_back('*');
        return true;
    }
    if((val%nums[idx]) == 0 && dfs(idx+1,val/nums[idx])){
        ops.push_back('/');
        return true;
    }
    return false;
}

int main()
{
    cin >> t;
    while(t--){
        cin >> n;
        visited = vector < unordered_set<int>>(n);
        ops.clear();
        nums.clear();
        for(int i=0;i < n;i++){
            cin >> v;
            nums.push_back(v);
        }
        cin >> target;
        if(dfs(1,nums[0])){
            for(int i=0;i < n;i++){
                cout << nums[i];
                if(i+1 != n) cout << ops[ops.size()-1-i];
                else printf("=%d\n",target);
            }
        } else printf("NO EXPRESSION\n">;
    }
}
Copy The Code & Try With Live Editor

Input

x
+
cmd
3
3 5 7 4 3
2 1 1 2000
5 12 2 5 1 2 4

Output

x
+
cmd
5+7/4=3
NO EXPRESSION
12-2/5*1*2=4
Advertisements

Demonstration


UVA Online Judge solution - 0400-Game Show Math - UVA Online Judge solution in C,C++,java

Previous
UVA Online Judge solution - 104-Arbitrage - UVA Online Judge solution in C,C++,java
Next
UVA Online Judge solution - 10405-Longest Common Subsequence UVA Online Judge solution in C,C++,java