Algorithm


problem Link  : https://onlinejudge.org/index.php?option=onlinejudge&page=show_problem&problem=1524  

There are so many different religions in the world today that it is difficult to keep track of them all. You are interested in finding out how many different religions students in your university believe in. You know that there are n students in your university (0 < n ≤ 50000). It is infeasible for you to ask every student their religious beliefs. Furthermore, many students are not comfortable expressing their beliefs. One way to avoid these problems is to ask m (0 ≤ m ≤ n(n − 1)/2) pairs of students and ask them whether they believe in the same religion (e.g. they may know if they both attend the same church). From this data, you may not know what each person believes in, but you can get an idea of the upper bound of how many different religions can be possibly represented on campus. You may assume that each student subscribes to at most one religion. Input The input consists of a number of cases. Each case starts with a line specifying the integers n and m. The next m lines each consists of two integers i and j, specifying that students i and j believe in the same religion. The students are numbered 1 to n. The end of input is specified by a line in which n = m = 0. Output For each test case, print on a single line the case number (starting with 1) followed by the maximum number of different religions that the students in the university believe in.

Sample Input 10 9 1 2 1 3 1 4 1 5 1 6 1 7 1 8 1 9 1 10 10 4 2 3 4 5 4 8 5 8 0 0

Sample Output Case 1: 1 Case 2: 7

Code Examples

#1 Code Example with C Programming

Code - C Programming

#include <bits/stdc++.h>
using namespace std;

int groupCount;

int udfsFind(int* udfs, int n){
    return udfs[n] == n ? n : udfsFind(udfs,udfs[n]);
}

void udfsJoin(int* udfs, int a, int b){
    if(udfsFind(udfs,a) == udfsFind(udfs,b)) return;
    udfs[udfsFind(udfs,a)] = udfsFind(udfs,b);
    groupCount--;
}

int main() {
    int n,m,a,b;
    int cases=1;
    while(scanf("%d %d",&n,&m),n||m){
        int udfs[n];
        groupCount = n;
        for(int i=0;i<n;i++) udfs[i] = i;
        for(int i=0;i < m;i++){
            cin >> a >> b;
            udfsJoin(udfs,a-1,b-1);
        }
        printf("Case %d: %d\n",cases++,groupCount>;
    }
}
Copy The Code & Try With Live Editor

Input

x
+
cmd
10 9
1 2
1 3
1 4
1 5
1 6
1 7
1 8
1 9
1 10
10 4
2 3
4 5
4 8
5 8
0 0

Output

x
+
cmd
Case 1: 1
Case 2: 7
Advertisements

Demonstration


UVA Online Judge solution - 10583-Ubiquitous Religions - UVA Online Judge solution in C,C++,java

Previous
UVA Online Judge solution - 10576-Y2K Accounting Bug - UVA Online Judge solution in C,C++,java
Next
UVA Online Judge solution -10583-Ubiquitous Religions - UVA Online Judge solution in C,C++,java