Algorithm


Problem link : https://onlinejudge.org/index.php?option=onlinejudge&Itemid=8&page=show_problem&problem=988

A monocycle is a cycle that runs on one wheel and the one we will be considering is a bit more special. It has a solid wheel colored with five different colors as shown in the figure: The colored segments make equal angles (72o ) at the center. A monocyclist rides this cycle on an M × N grid of square tiles. The tiles have such size that moving forward from the center of one tile to that of the next one makes the wheel rotate exactly 72o around its own center. The effect is shown in the above figure. When the wheel is at the center of square 1, the midpoint of the periphery of its blue segment is in touch with the ground. But when the wheel moves forward to the center of the next square (square 2) the midpoint of its white segment touches the ground. Some of the squares of the grid are blocked and hence the cyclist cannot move to them. The cyclist starts from some square and tries to move to a target square in minimum amount of time. From any square either he moves forward to the next square or he remains in the same square but turns 90o left or right. Each of these actions requires exactly 1 second to execute. He always starts his ride facing north and with the midpoint of the green segment of his wheel touching the ground. In the target square, too, the green segment must be touching the ground but he does not care about the direction he will be facing. Before he starts his ride, please help him find out whether the destination is reachable and if so the minimum amount of time he will require to reach it. Input The input may contain multiple test cases. The first line of each test case contains two integers M and N (1 ≤ M, N ≤ 25) giving the dimensions of the grid. Then follows the description of the grid in M lines of N characters each. The character ‘#’ will indicate a blocked square, all other squares are free. The starting location of the cyclist is marked by ‘S’ and the target is marked by ‘T’. The input terminates with two zeros for M and N. Output For each test case in the input first print the test case number on a separate line as shown in the sample output. If the target location can be reached by the cyclist print the minimum amount of time (in seconds) required to reach it exactly in the format shown in the sample output, otherwise, print “destination not reachable”. Print a blank line between two successive test cases.

Sample Input 1 3 S#T 10 10 #S.......# #..#.##.## #.##.##.## .#....##.# ##.##..#.# #..#.##... #......##. ..##.##... #.###...#. #.....###T 0 0

Sample Output Case #1 destination not reachable Case #2 minimum time = 49 sec

Code Examples

#1 Code Example with C Programming

Code - C Programming

 #include <bits/stdc++.h>
using namespace std;

vector < vector<int>> dirs = {{-1,0},{0,1},{1,0},{0,-1}};

int main() {
    int n,m,tc=1;
    int x,y,color,d;
    char c;
    while(scanf("%d %d",&n,&m),(n+m)){
        if(tc > 1) printf("\n");
        vector<vector < char>> grid;
        int sx, sy, tx, ty;
        for(int i=0;i < n;i++> {
            vector<char> row;
            for(int j=0;j < m;j++) {
                cin >> c;
                row.push_back(c);
                if(c == 'T') {
                    tx = i, ty = j;
                } else if(c == 'S') {
                    sx = i, sy = j;
                }
            }
            grid.push_back(row);
        }
        // state: x,y,color,dir
        vector < vector<vector<vector<bool>>>> visited(n,vector < vector<vector<bool>>>(m, vector < vector<bool>>(5,vector < bool>(4))));
        visited[sx][sy][0][0] = true;
        queue < vector<int>> bfs;
        bfs.push({sx,sy,0,0});

        int steps = 0;
        bool solved = false;
        while(!bfs.empty() && !solved) {
            int len = bfs.size();
            for(int i=0;i < len;i++) {
                x = bfs.front()[0], y = bfs.front()[1], color = bfs.front()[2], d = bfs.front()[3];
                bfs.pop();
                if(x == tx && y == ty && color == 0) {
                    solved = true;
                    break;
                }
                // switch direction
                for (int lr : {1,3}) {
                    int nextD = (d+lr) % 4;
                    if(!visited[x][y][color][nextD])
                        visited[x][y][color][nextD] = true, bfs.push({x,y,color,nextD});
                }
                // forward move
                int nextX = x+dirs[d][0], nextY = y+dirs[d][1], nextColor = (color+1)%5;
                if(nextX  < 0 || nextX >= n || nextY < 0 || nextY >= m) continue;
                if(grid[nextX][nextY] == '#' || visited[nextX][nextY][nextColor][d]) continue;
                visited[nextX][nextY][nextColor][d] = true, bfs.push({nextX,nextY,nextColor,d});
            }
            if(!solved) steps++;
        }
        printf("Case #%d\n", tc++);
        if (solved) printf("minimum time = %d sec\n", steps);
        else printf("destination not reachable\n");
    }
}
Copy The Code & Try With Live Editor

Input

x
+
cmd
1 3
S#T
10 10
#S.......#
#..#.##.##
#.##.##.##
.#....##.#
##.##..#.#
#..#.##...
#......##.
..##.##...
#.###...#.
#.....###T
0 0

Output

x
+
cmd
Case #1
destination not reachable
Case #2
minimum time = 49 sec
Advertisements

Demonstration


UVA Online Judge solution - 10047 - The Monocycle - UVA Online Judge solution in C,C++,Java

Previous
#492 - UVA Online Judge solution Pig Latine - 492 - Pig-Latin - Solution in C, C++, Java, PHP, Python, C#
Next
UVA Online Judge solution - 10048 - Audiophobia - UVA Online Judge solution in C,C++,Java