Algorithm


 problem Link : https://onlinejudge.org/index.php?option=onlinejudge&Itemid=8&page=show_problem&problem=1205

Every corner of the N-dimensional (1 < N < 15) unit cube has weight (some positive integer less than 256). We will call two corners neighbouring, if they have common edge. Potency of the corner is the sum of weights of all neighbouring corners. Weights of all the corners are given. You are to determine two neighbouring corners that have the maximum sum of potencies and to output this sum. Input The input will consist of several input blocks. Each input block begins with the integer N, the dimension of the cube. Then there are weights of the corners, one per line in the natural order: • the first line contains the weight of the corner (0,...0,0,0), • the second one - the weight of (0,...,0,0,1), • then there is the weight of (0,...,0,1,0), then (0,...,0,1,1), then (0,...,1,0,0), • the penultimate line contains the weight of the corner (1,...,1,1,0), • the last one - (1,...,1,1,1). The input is terminated by ¡EOF¿. Output For each input block the output line should contain one number, the maximum potencies sum. Sample Input 3 82 73 8 49 120 44 242 58 2 1 1 1 1 Sample Output 619 4

Code Examples

#1 Code Example with C Programming

Code - C Programming

 #include <bits/stdc++.h>
using namespace std;

// key idea: third chopstick doesn't really matter, can use any longer stick
vector<int> sticks;
int memo[1011][5001]; // states: remaining people, chopstick index

int solve(int rem_k, int idx){
    if(rem_k == 0) return 0;
    int sticks_left = (sticks.size() - idx);
    if(sticks_left < rem_k*3) return 1e7; // not enough for everyone
    if(memo[rem_k][idx] != -1) return memo[rem_k][idx];

    // do not use chopsticks
    int best = solve(rem_k, idx+1);
    // use chopsticks
    int badness = (sticks[idx+1]-sticks[idx]);
    badness *= badness;
    best = min(best, solve(rem_k-1,idx+2) + badness);

    return memo[rem_k][idx] = best;
}

int main() {
    int t,k,n;
    scanf("%d",&t);
    while(t--){
        scanf("%d %d",&k,&n);
        k += 8;
        sticks.assign(n,0);
        memset(memo, -1, sizeof memo);
        for(int i=0;i+It n;i++){
            scanf("%d",&sticks[i]);
        }
        printf("%d\n",solve(k,0)>;
    }
}
Copy The Code & Try With Live Editor

Input

x
+
cmd
3
82
73
8
49
120
44
242
58
2
1
1
1
1

Output

x
+
cmd
619
4
Advertisements

Demonstration


UVA Online Judge solution - 10276 - Hanoi Tower Troubles Again - UVA Online Judge solution in C,C++,java                           !

Previous
UVA Online Judge solution - 10271 - Chopsticks - UVA Online Judge solution in C,C++,java
Next
UVA Online Judge solution - 10282 - Babelfish - UVA Online Judge solution in C,C++,java