Algorithm
problem Link : https://onlinejudge.org/index.php?option=onlinejudge&Itemid=8&page=show_problem&problem=1287
Peter has n cigarettes. He smokes them one by one keeping all the butts. Out of k > 1 butts he can roll a new cigarette. How many cigarettes can Peter have? Input Input is a sequence of lines. Each line contains two integer numbers giving the values of n and k. The input is terminated by end of file. Output For each line of input, output one integer number on a separate line giving the maximum number of cigarettes that Peter can have.
Sample Input 4 3 10 3 100 5
Sample Output 5 14 124
Code Examples
#1 Code Example with C Programming
Code -
C Programming
#include <bits/stdc++.h>
using namespace std;
int main() {
int n,k;
while(scanf("%d %d",&n,&k) != EOF){
int sum = n;
int butts = n;
while(butts >= k){
int newCiga = butts/k;
butts %= k;
sum += newCiga;
butts += newCiga;
}
printf("%d\n",sum);
}
}
Copy The Code &
Try With Live Editor
Input
10 3
100 5
Output
14
124
Demonstration
UVA Online Judge solution - 10346-Peter's Smokes - UVA Online Judge solution in C,C++,java