Algorithm


problem Link : https://onlinejudge.org/index.php?option=onlinejudge&Itemid=8&page=show_problem&problem=1281 

You have devised a new encryption technique which encodes a message by inserting between its characters randomly generated strings in a clever way. Because of pending patent issues we will not discuss in detail how the strings are generated and inserted into the original message. To validate your method, however, it is necessary to write a program that checks if the message is really encoded in the final string. Given two strings s and t, you have to decide whether s is a subsequence of t, i.e. if you can remove characters from t such that the concatenation of the remaining characters is s. Input The input contains several testcases. Each is specified by two strings s, t of alphanumeric ASCII characters separated by whitespace. Input is terminated by EOF. Output For each test case output, if s is a subsequence of t.

Sample Input sequence subsequence person compression VERDI vivaVittorioEmanueleReDiItalia caseDoesMatter CaseDoesMatter

Sample Output Yes No Yes No

Code Examples

#1 Code Example with C Programming

Code - C Programming

#include <bits/stdc++.h>

using namespace std;

bool isSubseq(const string& a, const string& b){
    if(a.size() > b.size()) return false;
    int i=0;
    for(int j=0;j<b.length() && i < a.size();j++){
        if(b[j] == a[i]) i++;
    }
    return i==a.size();
}

int main()
{
    string pattern,str;
    while(cin >> pattern){
        cin >> str;
        cout << (isSubseq(pattern,str) ? "Yes" : "No"> << endl;
    }
}
Copy The Code & Try With Live Editor

Input

x
+
cmd
sequence subsequence
person compression
VERDI vivaVittorioEmanueleReDiItalia
caseDoesMatter CaseDoesMatter

Output

x
+
cmd
Yes
No
Yes
No
Advertisements

Demonstration


UVA Online Judge solution - 10340-All in All  - UVA Online Judge solution in C,C++,java

Previous
UVA Online Judge solution - 10338 - Mischievous Children - UVA Online Judge solution in C,C++,java
Next
UVA Online Judge solution - 10341 - Solve It - UVA Online Judge solution in C,C++,java