Algorithm


 problem Link : https://onlinejudge.org/index.php?option=onlinejudge&Itemid=8&page=show_problem&problem=1975 

Before bridges were common, ferries were used to transport cars across rivers. River ferries, unlike their larger cousins, run on a guide line and are powered by the river’s current. Cars drive onto the ferry from one end, the ferry crosses the river, and the cars exit from the other end of the ferry. There is an l-meter-long ferry that crosses the river. A car may arrive at either river bank to be transported by the ferry to the opposite bank. The ferry travels continuously back and forth between the banks so long as it is carrying a car or there is at least one car waiting at either bank. Whenever the ferry arrives at one of the banks, it unloads its cargo and loads up cars that are waiting to cross as long as they fit on its deck. The cars are loaded in the order of their arrival; ferry’s deck accommodates only one lane of cars. The ferry is initially on the left bank where it broke and it took quite some time to fix it. In the meantime, lines of cars formed on both banks that await to cross the river. Input The first line of input contains c, the number of test cases. Each test case begins with l, m. m lines follow describing the cars that arrive in this order to be transported. Each line gives the length of a car (in centimeters), and the bank at which the car arrives (‘left’ or ‘right’). Output For each test case, output one line giving the number of times the ferry has to cross the river in order to serve all waiting cars.

Sample Input 4 20 4 380 left 720 left 1340 right 1040 left 15 4 380 left 720 left 1340 right 1040 left 15 4 380 left 720 left 1340 left 1040 left 15 4 380 right 720 right 1340 right 1040 right

Sample Output 3 3 5 6

Code Examples

#1 Code Example with C Programming

Code - C Programming

 #include <iostream>
#include <fstream>
#include <sstream>
#include <iomanip>
#include <cmath>
#include <stdio.h>
#include <limits.h>
#include <string.h>
#include <vector>
#include <algorithm>
#include <set>
#include <map>
#include <unordered_map>
#include <unordered_set>
#include <list>
#include <deque>
#include <queue>
#include <stack>
using namespace std;

int main() {
    int n, l, m, v;
    string in;
    cin >> n;
    while(n--){
        cin >> l >> m;
        l *= 100;
        queue < int> left, right;
        int res = 0;
        bool onLeft = true;
        for(int i=0;i < m;i++){
            cin >> v >> in;
            if(in == "left") left.push(v);
            else right.push(v);
        }
        while(!left.empty() || !right.empty()){
            int capacity = l;
            res++;
            if(onLeft){
                while(!left.empty() && capacity >= left.front()){
                    capacity -= left.front(); left.pop();
                }
            } else {
                while(!right.empty() && capacity >= right.front()){
                    capacity -= right.front(); right.pop();
                }
            }
            onLeft = !onLeft;
        }
        cout << res << endl;
    }
}
 
Copy The Code & Try With Live Editor

Input

x
+
cmd
4
20 4
380 left
720 left
1340 right
1040 left
15 4
380 left
720 left
1340 right
1040 left
15 4
380 left
720 left
1340 left
1040 left
15 4
380 right
720 right
1340 right
1040 right

Output

x
+
cmd
3
3
5
6
Advertisements

Demonstration


UVA Online Judge solution - 11034-Ferry Loading IV - UVA Online Judge solution in C,C++,java

Previous
UVA Online Judge solution - 11026-A Grouping Problem - UVA Online Judge solution in C,C++,java
Next
UVA Online Judge solution - 11039-Building designing - UVA Online Judge solution in C,C++,java