Algorithm
problem Link : https://onlinejudge.org/index.php?option=onlinejudge&Itemid=8&page=show_problem&problem=2000
Given a sequence of integers S = {S1, S2, . . . , Sn}, you should determine what is the value of the maximum positive product involving consecutive terms of S. If you cannot find a positive sequence, you should consider 0 as the value of the maximum product. Input Each test case starts with 1 ≤ N ≤ 18, the number of elements in a sequence. Each element Si is an integer such that −10 ≤ Si ≤ 10. Next line will have N integers, representing the value of each element in the sequence. There is a blank line after each test case. The input is terminated by end of file (EOF). Output For each test case you must print the message: ‘Case #M: The maximum product is P.’, where M is the number of the test case, starting from 1, and P is the value of the maximum product. After each test case you must print a blank line.
Sample Input 3 2 4 -3 5 2 5 -1 2 -1
Sample Output Case #1: The maximum product is 8. Case #2: The maximum product is 20.
Code Examples
#1 Code Example with C Programming
Code -
C Programming
#include <bits/stdc++.h>
using namespace std;
// O(N) dynamic programming
// track largest negative number and cumulative product
int main()
{
int n,v;
int cases = 1;
while(scanf("%d",&n) != EOF){
long long largestNeg = 0;
long long dpProd = 1;
long long res = 0;
for(int i=0;i < n;i++){
cin >> v;
dpProd *= v;
if(dpProd == 0){
largestNeg = 0;
dpProd = 1;
} else if(dpProd > 0){
res = max(res,dpProd);
} else {
if(largestNeg) res = max(res,dpProd/largestNeg);
else largestNeg = dpProd;
largestNeg = max(largestNeg,dpProd);
}
}
printf("Case #%d: The maximum product is %lld.\n\n",cases++,res);
}
}
Copy The Code &
Try With Live Editor
Input
2 4 -3
5
2 5 -1 2 -1
Output
Case #2: The maximum product is 20.
Demonstration
UVA Online Judge solution - 11059-Maximum Product - UVA Online Judge solution in C,C++,java