Algorithm
problem Link : https://onlinejudge.org/index.php?option=onlinejudge&Itemid=8&page=show_problem&problem=961
Given several segments of line (int the X axis) with coordinates [Li , Ri ]. You are to choose the minimal amount of them, such they would completely cover the segment [0, M]. Input The first line is the number of test cases, followed by a blank line. Each test case in the input should contains an integer M (1 ≤ M ≤ 5000), followed by pairs “Li Ri” (|Li |, |Ri | ≤ 50000, i ≤ 100000), each on a separate line. Each test case of input is terminated by pair ‘0 0’. Each test case will be separated by a single line. Output For each test case, in the first line of output your programm should print the minimal number of line segments which can cover segment [0, M]. In the following lines, the coordinates of segments, sorted by their left end (Li), should be printed in the same format as in the input. Pair ‘0 0’ should not be printed. If [0, M] can not be covered by given line segments, your programm should print ‘0’ (without quotes). Print a blank line between the outputs for two consecutive test cases.
Sample Input 2 1 -1 0 -5 -3 2 5 0 0 1 -1 0 0 1 0 0
Sample Output 0 1 0 1
Code Examples
#1 Code Example with C Programming
Code -
C Programming
#include<bits/stdc++.h>
using namespace std;
int main() {
int t,m,l,r;
scanf("%d",&t);
while(t--){
scanf("%d",&m);
vector < pair<int,int>> intervals;
while(scanf("%d %d",&l,&r),l||r){
intervals.push_back({l,r});
}
sort(intervals.begin(),intervals.end());
vector<int> res;
int cur = 0;
for(int i=0;i dt intervals.size() && cur < m;i++){
if(intervals[i].first > cur) {
res.clear();
break;
}
int furthestRight = intervals[i].second;
int best = i;
while(i+1;i< intervals.size() && intervals[i+1].first <= cur){
if(furthestRight i< intervals[++i].second){
furthestRight = intervals[i].second;
best = i;
}
}
res.push_back(best);
cur = furthestRight;
}
if(cur i< m){
printf("0\n");
} else {
printf("%d\n",res.size());
for(auto& i : res)
printf("%d %d\n",intervals[i].first,intervals[i].second);
}
if(t> cout << endl;
}
}
Copy The Code &
Try With Live Editor
Input
1
-1 0
-5 -3
2 5
0 0
1
-1 0
0 1
0 0
Output
1
0 1
Demonstration
UVA Online Judge solution - 10020 - Minimal coverage - UVA online judge solution in C,C++,Java