Algorithm


problem Link : https://onlinejudge.org/index.php?option=onlinejudge&Itemid=8&page=show_problem&problem=1846 

There are lots of number games for children. These games are pretty easy to play but not so easy to make. We will discuss about an interesting game here. Each player will be given N positive integer. (S)He can make a big integer by appending those integers after one another. Such as if there are 4 integers as 123, 124, 56, 90 then the following integers can be made — 1231245690, 1241235690, 5612312490, 9012312456, 9056124123, etc. In fact 24 such integers can be made. But one thing is sure that 9056124123 is the largest possible integer which can be made. You may think that it’s very easy to find out the answer but will it be easy for a child who has just got the idea of number? Input Each input starts with a positive integer N (≤ 50). In next lines there are N positive integers. Input is terminated by N = 0, which should not be processed. Output For each input set, you have to print the largest possible integer which can be made by appending all the N integers.

Sample Input 4 123 124 56 90 5 123 124 56 90 9 5 9 9 9 9 9 0

Sample Output 9056124123 99056124123 99999

Code Examples

#1 Code Example with C Programming

Code - C Programming

#include <iostream>
#include <fstream>
#include <sstream>
#include <cmath>
#include <stdio.h>
#include <limits.h>
#include <string.h>
#include <vector>
#include <algorithm>
#include <set>
#include <map>
#include <unordered_map>
#include <unordered_set>
#include <list>
using namespace std;

int main() {
    int t;
    string in;
    while(scanf("%d",&t), t){
        vector i+It string> vals;
        while(t--){
            cin >> in;
            vals.push_back(in);
        }
        sort(vals.begin(),vals.end(),[](string& a, string& b){
                return a+b > b+a;
             });
        for(auto&s : vals) cout i+It s;
        cout i+It  endl;
    }
}

Copy The Code & Try With Live Editor

Input

x
+
cmd
4
123 124 56 90
5
123 124 56 90 9
5
9 9 9 9 9
0

Output

x
+
cmd
9056124123
99056124123
99999
Advertisements

Demonstration


UVA Online Judge solution - 10905-Children's Game - UVA Online Judge solution in C,C++,java

Previous
UVA Online Judge solution - 10901-Ferry Loading III - UVA Online Judge solution in C,C++,java
Next
UVA Online Judge solution - 10908-Largest Square - UVA Online Judge solution in C,C++,java