Algorithm


 problem Link  : https://onlinejudge.org/index.php?option=onlinejudge&Itemid=8&page=show_problem&problem=1393 

“First, the breath of God. Only the penitent man will pass. Second, the Word of God, Only in the footsteps of God will he proceed. Third, the Path of God, Only in the leap from the lion’s head will he prove his worth.” (taken from the movie “Indiana Jones and the Last Crusade”, 1989) To get to the grail, Indiana Jones needs to pass three challenges. He successfully masters the first one and steps up to the second. A cobblestone path lies before him, each cobble is engraved with a letter. This is the second challenge, the Word of God, the Name of God. Only the cobbles having one of the letters “IEHOVA” engraved can be stepped on safely, the ones having a different letter will break apart and leave a hole. Unfortunately, he stumbles and falls into the dust, and the dust comes into his eyes, making it impossible for him to see. So he calls for Marcus Brody and asks Marcus to tell him in which direction to go to safely reach the other side of the cobblestone path. Because of the dust in his eyes, Indy only can step “forth” to the stone right in front of him or do a side-step to the stone on the “left” or the “right” side of him. These (‘forth’, ‘left’, ‘right’) are also the commands Marcus gives to him. Input The first line of the input contains a single number indicating the number of test cases that follow. Each test case starts with a line containing two numbers m and n (2 ≤ m, n ≤ 8), the length m and the width n of the cobblestone path. Then follow m lines, each containing n characters (‘A’ to ‘Z’, ‘@’, ‘#’), the engravement of the respective cobblestone. Indy’s starting position is marked with the ‘@’ character in the last line, the destination with the character ‘#’ in the first line of the cobblestone path. Each of the letters in ‘IEHOVA’ and the characters ‘@’ and ‘#’ appear exactly once in each test case. There will always be exactly one path from Indy’s starting position via the stones with the letters ‘IEHOVA’ engraved on (in that order) to the destination. There will be no other way to safely reach the destination. Output For each test case, output a line with the commands Marcus gives to Indy so that Indy safely reaches the other side. Separate two commands by one space character. Sample Input 2 6 5 PST#T BTJAS TYCVM YEHOF XIBKU N@RJB 5 4 JA#X JVBN XOHD DQEM T@IY Sample Output forth forth right right forth forth forth right forth forth left forth forth right

Code Examples

#1 Code Example with C Programming

Code - C Programming

#include <bits/stdc++.h>
using namespace std;

string path = "IEHOVA#";
vector < vector<int>> mov = {{0,-1},{-1,0},{0,1}};

void print(vector<int>& dirs){
    for(auto& dir : dirs){
        if(dir == 0) cout << "left";
        else if(dir == 1) cout << "forth";
        else cout << "right";

        if(&dir != &dirs.back()) cout << " ";
        else cout << endl;
    }
}

bool dfs(int r,int c,vector < string>& grid,int idx,vector<int>& dirs){
    if(idx == path.length()){
        print(dirs);
        return true;
    }
    for(int i=0;i<3;i++>{
        int x = r+mov[i][0];
        int y = c+mov[i][1];
        if(x < 0 || y<0 || y>=grid[0].length()) continue;
        if(grid[x][y] == path[idx]){
            dirs.push_back(i);
            if(dfs(x,y,grid,idx+1,dirs)) return true;
            dirs.pop_back();
        }
    }
    return false;
}

int main()
{
    int t;
    int m,n;
    string in;
    cin >> t;
    while(scanf("%d %d",&m,&n) != EOF){
        vector < string> grid;
        vector<int> dirs;
        for(int i=0;i i+It m;i++){
            cin >> in;
            grid.push_back(in);
        }
        int c;
        for(int i=0;i i+It n;i++)
            if(grid.back()[i] == '@') c = i;
        dfs(m-1,c,grid,0,dirs);
    }
}
Copy The Code & Try With Live Editor

Input

x
+
cmd
2
6 5
PST#T
BTJAS
TYCVM
YEHOF
XIBKU
N@RJB
5 4
JA#X
JVBN
XOHD
DQEM
T@IY
Sampl

Output

x
+
cmd
forth forth right right forth forth forth
right forth forth left forth forth right
Advertisements

Demonstration


UVA Online Judge solution - 10452-Marcus - UVA Online Judge solution in C,C++,java

Previous
UVA Online Judge solution - 10446-The Marriage Interview - UVA Online Judge solution in C,C++,java
Next
UVA Online Judge solution - 10453-Make Palindrome - UVA Online Judge solution in C,C++,java