Algorithm


 problem Link :  https://onlinejudge.org/index.php?option=onlinejudge&Itemid=8&page=show_problem&problem=945

In 1976 the “Four Color Map Theorem” was proven with the assistance of a computer. This theorem states that every map can be colored using only four colors, in such a way that no region is colored using the same color as a neighbor region. Here you are asked to solve a simpler similar problem. You have to decide whether a given arbitrary connected graph can be bicolored. That is, if one can assign colors (from a palette of two) to the nodes in such a way that no two adjacent nodes have the same color. To simplify the problem you can assume: • no node will have an edge to itself. • the graph is nondirected. That is, if a node a is said to be connected to a node b, then you must assume that b is connected to a. • the graph will be strongly connected. That is, there will be at least one path from any node to any other node. Input The input consists of several test cases. Each test case starts with a line containing the number n (1 < n < 200) of different nodes. The second line contains the number of edges l. After this, l lines will follow, each containing two numbers that specify an edge between the two nodes that they represent. A node in the graph will be labeled using a number a (0 ≤ a < n). An input with n = 0 will mark the end of the input and is not to be processed. Output You have to decide whether the input graph can be bicolored or not, and print it as shown below.

Sample Input 3 3 0 1 1 2 2 0 3 2 0 1 1 2 9 8 0 1 0 2 0 3 0 4 0 5 0 6 0 7 0 8 0

Sample Output NOT BICOLORABLE.

BICOLORABLE. BICOLORABLE.

Code Examples

#1 Code Example with C Programming

Code - C Programming

 
#include<bits/stdc++.h>
using namespace std;

int main()
{
    int n,l,a,b;
    while(scanf("%d",&n),n){
        scanf("%d",&l);
        unordered_map < int,unordered_set<int>> graph;
        for(int i=0;i < l;i++){
            scanf("%d %d",&a,&b);
            graph[a].insert(b);
            graph[b].insert(a);
        }
        queue < int> q; q.push(0);
        vector<int> color(n);
        color[0] = 1;
        bool isBipartile = true;
        while(!q.empty() & isBipartile){
            int cur = q.front(); q.pop();
            int curColor = color[cur];
            for(int neighbor : graph[cur]){
                if(color[neighbor] == curColor){
                    isBipartile = false;
                    break;
                } else if(color[neighbor] == 0){
                    // not yet colored
                    color[neighbor] = -curColor;
                    q.push(neighbor);
                }
            }
        }
        if(isBipartile) printf("BICOLORABLE.\n");
        else printf("NOT BICOLORABLE.\n");
    }
}
Copy The Code & Try With Live Editor

Input

x
+
cmd
3
3
0 1
1 2
2 0
3
2
0 1
1 2
9
8
0 1
0 2
0 3
0 4
0 5
0 6
0 7
0 8
0

Output

x
+
cmd
NOT BICOLORABLE
BICOLORABLE
BICOLORA
Advertisements

Demonstration


UVA Online Judge solution 10004-Bicoloring  UVA online judge solution in C,C++,Java

Previous
UVA Online Judge solution -10003 - Cutting Sticks - UVA online judge solution in C,C++
Next
UVA Online Judge solution - 10005-Packing polygons - UVA Online Judge solution in C,C++