Algorithm


problem Link : https://onlinejudge.org/index.php?option=onlinejudge&Itemid=8&page=show_problem&problem=1742 

Ted the bellhop: “I’m coming up and if there isn’t a dead body by the time I get there, I’ll make one myself. You!” Robert Rodriguez, "Four Rooms." A skyscraper has no more than 100 floors, numbered from 0 to 99. It has n (1 ≤ n ≤ 5) elevators which travel up and down at (possibly) different speeds. For each i in {1, 2, . . . n}, elevator number i takes Ti (1 ≤ Ti ≤ 100) seconds to travel between any two adjacent floors (going up or down). Elevators do not necessarily stop at every floor. What’s worse, not every floor is necessarily accessible by an elevator. You are on floor 0 and would like to get to floor k as quickly as possible. Assume that you do not need to wait to board the first elevator you step into and (for simplicity) the operation of switching an elevator on some floor always takes exactly a minute. Of course, both elevators have to stop at that floor. You are forbiden from using the staircase. No one else is in the elevator with you, so you don’t have to stop if you don’t want to. Calculate the minimum number of seconds required to get from floor 0 to floor k (passing floor k while inside an elevator that does not stop there does not count as “getting to floor k”). Input The input will consist of a number of test cases. Each test case will begin with two numbers, n and k, on a line. The next line will contain the numbers T1, T2, . . . Tn. Finally, the next n lines will contain sorted lists of integers – the first line will list the floors visited by elevator number 1, the next one will list the floors visited by elevator number 2, etc. Output For each test case, output one number on a line by itself - the minimum number of seconds required to get to floor k from floor 0. If it is impossible to do, print ‘IMPOSSIBLE’ instead. Explanation of examples In the first example, take elevator 1 to floor 13 (130 seconds), wait 60 seconds to switch to elevator 2 and ride it to floor 30 (85 seconds) for a total of 275 seconds. In the second example, take elevator 1 to floor 10, switch to elevator 2 and ride it until floor 25. There, switch back to elevator 1 and get off at the 30’th floor. The total time is 10 ∗ 10 + 60 + 15 ∗ 1 + 60 + 5 ∗ 10 = 285 seconds. In example 3, take elevator 1 to floor 30, then elevator 2 to floor 20 and then elevator 3 to floor 50. In the last example, the one elevator does not stop at floor 1.

Sample Input 2 30 10 5 0 1 3 5 7 9 11 13 15 20 99 4 13 15 19 20 25 30 2 30 10 1 0 5 10 12 14 20 25 30 2 4 6 8 10 12 14 22 25 28 29 3 50 10 50 100 0 10 30 40 0 20 30 0 20 50 1 1 2 0 2 4 6 8 10

Sample Output 275 285 3920 IMPOSSIBLE

Code Examples

#1 Code Example with C Programming

Code - C Programming

 #include <bits/stdc++.h>

using namespace std;
// state: current level, current elevator
// we can also use a single state space by building a graph that merges the two state
int main()
{
    int n,k,t,v;
    string in;
    while(scanf("%d %d",&n,&k) != EOF){
        vector<int> elevator_time;
        vector < vector<int>> dist(100,vector<int>(5,1e7));
        for(int i=0;i < 5;i++)
            dist[0][i] = 0;
        priority_queue < tuple<int,int,int>,vector<tuple<int,int,int>>,greater < tuple<int,int,int>>> pq;
        for(int i=0;i < n;i++){
            scanf("%d",&t);
            elevator_time.push_back(t);
        }
        cin.ignore();
        // elevator x can go to what level?
        vector < vector<int>> edges(n,vector<int>()); // elevator to level
        vector < vector<int>> floorElevator(100,vector<int>()); // level to elevator
        for(int i=0;i < n;i++){
            getline(cin,in);
            istringstream iss(in);
            while(iss >> v){
                edges[i].push_back(v);
                floorElevator[v].push_back(i);
                if(v == 0){
                    pq.push(make_tuple(0,0,i));
                }
            }
        }
        while(!pq.empty()){
            int cost,level,elevator;
            tie(cost,level,elevator) = pq.top(); pq.pop();
            if(cost > dist[level][elevator]) continue;
            // use same elevator to go to other floors
            for(int neigh : edges[elevator]){
                int nextCost = cost + abs(level-neigh)*elevator_time[elevator];
                if(nextCost < dist[neigh][elevator]){
                    pq.push(make_tuple(nextCost,neigh,elevator));
                    dist[neigh][elevator] = nextCost;
                }
            }
            // switch to other elevator
            for(int otherElevator : floorElevator[level]){
                int nextCost = cost + 60;
                if(nextCost  <  dist[level][otherElevator]){
                    pq.push(make_tuple(nextCost,level,otherElevator));
                    dist[level][otherElevator] = nextCost;
                }
            }
        }
        int res = 1e7;
        for(int i=0;i < 5;i++) res = min(res,dist[k][i]>;
        if(res >= 1e7) printf("IMPOSSIBLE\n");
        else printf("%d\n",res);
    }
}
Copy The Code & Try With Live Editor

Input

x
+
cmd
2 30
10 5
0 1 3 5 7 9 11 13 15 20 99
4 13 15 19 20 25 30
2 30
10 1
0 5 10 12 14 20 25 30
2 4 6 8 10 12 14 22 25 28 29
3 50
10 50 100
0 10 30 40
0 20 30
0 20 50
1 1
2
0 2 4 6 8 10

Output

x
+
cmd
275
285
3920
IMPOSSIBLE
Advertisements

Demonstration


UVA Online Judge solution -10801-Lift Hopping - UVA Online Judge solution in C,C++,java

Previous
UVA Online Judge solution - 108-Maximum Sum - UVA Online Judge solution in C,C++,java
Next
UVA Online Judge solution -10812-Beat the Spread! - UVA Online Judge solution in C,C++,java