Algorithm


problem Link : https://onlinejudge.org/index.php?option=com_onlinejudge&Itemid=8&category=24&page=show_problem&problem=1753 

Superbowl Sunday is nearly here. In order to pass the time waiting for the half-time commercials and wardrobe malfunctions, the local hackers have organized a betting pool on the game. Members place their bets on the sum of the two final scores, or on the absolute difference between the two scores. Given the winning numbers for each type of bet, can you deduce the final scores? Input The first line of input contains n, the number of test cases. n lines follow, each representing a test case. Each test case gives s and d, non-negative integers representing the sum and (absolute) difference between the two final scores. Output For each test case, output a line giving the two final scores, largest first. If there are no such scores, output a line containing “impossible”. Recall that football scores are always non-negative integers.

Sample Input 2 40 20 20 40

Sample Output 30 10 impossible

Code Examples

#1 Code Example with C Programming

Code - C Programming

 #include <bits/stdc++.h>
using namespace std;
int fastio() { ios_base::sync_with_stdio(false); cout << fixed << setprecision(10); cin.tie(nullptr); return 0; }

int __fastio = fastio();
typedef long long ll;

const string IMP = "impossible";
void solve() {
	ll s, d;
	cin >> s >> d;
	ll a2 = s+d;
	if(a2%2) {
		cout << IMP << "\n";
		return;
	}
	ll a = a2/2;
	ll b = s-a;
	if(b<0) {
		cout << IMP << "\n";
		return;
	}
	cout << a << " " << b << "\n";
}

int main() {
    int t=1;
	  cin >> t;
    while(t--) {
        solve(>;
    }
}

Copy The Code & Try With Live Editor

Input

x
+
cmd
2
40 20
20 40

Output

x
+
cmd
30 10
impossible
Advertisements

Demonstration


UVA Online Judge solution -10812-Beat the Spread! - UVA Online Judge solution in C,C++,java

Previous
UVA Online Judge solution -10801-Lift Hopping - UVA Online Judge solution in C,C++,java
Next
UVA Online Judge solution - 10814-Simplifying Fractions - UVA Online Judge solution in C,C++,java