Algorithm


 problem Link : https://onlinejudge.org/index.php?option=onlinejudge&page=show_problem&problem=1246 :

John has n tasks to do. Unfortunately, the tasks are not independent and the execution of one task is only possible if other tasks have already been executed. Input The input will consist of several instances of the problem. Each instance begins with a line containing two integers, 1 ≤ n ≤ 100 and m. n is the number of tasks (numbered from 1 to n) and m is the number of direct precedence relations between tasks. After this, there will be m lines with two integers i and j, representing the fact that task i must be executed before task j. An instance with n = m = 0 will finish the input. Output For each instance, print a line with n integers representing the tasks in a possible order of execution.

Sample Input 5 4 1 2 2 3 1 3 1 5 0 0

Sample Output 1 4 2 5 3

Code Examples

#1 Code Example with C Programming

Code - C Programming

 #include<bits/stdc++.h>
using namespace std;
int n,m,a,b;
vector < bool> visited;
unordered_map<int,unordered_set<int>> graph;

void dfs(int cur,stack < int>& topo){
    visited[cur] = true;
    for(auto& successor : graph[cur])
        if(!visited[successor])
            dfs(successor,topo);
    topo.push(cur);
}

int main()
{
    while(scanf("%d %d",&n,&m),(n+m)!=0){
        visited.assign(n+1,false);
        graph.clear();
        for(int i=0;i<m;i++){
            cin >> a >> b;
            graph[a].insert(b>;
        }
        stack < int> topological;
        for(int i=1;i < =n;i++)
            if(!visited[i])
                dfs(i,topological);
        while(!topological.empty()){
            printf("%d",topological.top());
            topological.pop();
            if(topological.empty()) printf("\n");
            else printf(" ");
        }
    }
}
Copy The Code & Try With Live Editor

Input

x
+
cmd
5 4
1 2
2 3
1 3
1 5
0 0

Output

x
+
cmd
1 4 2 5 3
Advertisements

Demonstration


UVA Online Judge solution - 10305 - Ordering Tasks - uVA Online Judge solution in C,C++,java

Previous
UVA Online Judge solution 10302 - Summation of Polynomials - UVA Online Judge solution in C,C++,java
Next
UVA Online Judge solution 10306 - e - Coins - UVA Online Judge solution in C,C++,java