Algorithm


problem Link :  https://onlinejudge.org/index.php?option=onlinejudge&Itemid=8&page=show_problem&problem=1884 

Larry is very bad at math — he usually uses a calculator, which worked well throughout college. Unforunately, he is now struck in a deserted island with his good buddy Ryan after a snowboarding accident. They’re now trying to spend some time figuring out some good problems, and Ryan will eat Larry if he cannot answer, so his fate is up to you! It’s a very simple problem — given a number N, how many ways can K numbers less than N add up to N? For example, for N = 20 and K = 2, there are 21 ways: 0+20 1+19 2+18 3+17 4+16 5+15 ... 18+2 19+1 20+0 Input Each line will contain a pair of numbers N and K. N and K will both be an integer from 1 to 100, inclusive. The input will terminate on 2 0’s. Output Since Larry is only interested in the last few digits of the answer, for each pair of numbers N and K, print a single number mod 1,000,000 on a single line.

Sample Input 20 2 20 2 0 0

Sample Output 21 21

Code Examples

#1 Code Example with C Programming

Code - C Programming

 #include <bits/stdc++.h>
using namespace std;

int main()
{
    int dp[101][101] = {};
    dp[0][0] = 1;
    // dp[n][k] = sum of dp[i][k-1] for i=0 to n
    // for each k
    for(int i=1;i < 101;i++){
        // for each number n
        int sum = 0;
        for(int j=0;j < 101;j++){
            sum = (sum+dp[j][i-1])%1000000;
            dp[j][i] = sum;
        }
    }
    int n,k;
    while(scanf("%d %d",&n,&k),(n+k) != 0){
        printf("%d\n",dp[n][k]);
    }
}
 
Copy The Code & Try With Live Editor

Input

x
+
cmd
20 2
20 2
0 0

Output

x
+
cmd
21
21
Advertisements

Demonstration


UVA Online Judge solution - 10943-How do you add? - UVA Online Judge solution in C,C++,java

Previous
UVA Online Judge solution - 10935-Throwing cards away I - UVA Online Judge solution in C,C++,java
Next
UVA Online Judge solution - 10954-Add All - UVA Online Judge solution in C,C++,java