Algorithm


Problem Name: beecrowd | 1012

Area

Adapted by Neilor Tonin, URI Brazil

Timelimit: 1

Make a program that reads three floating point values: A, B and C. Then, calculate and show:
a) the area of the rectangled triangle that has base A and height C.
b) the area of the radius's circle C. (pi = 3.14159)
c) the area of the trapezium which has A and B by base, and C by height.
d) the area of ​​the square that has side B.
e) the area of the rectangle that has sides A and B.

Input

The input file contains three double values with one digit after the decimal point.

Output

The output file must contain 5 lines of data. Each line corresponds to one of the areas described above, always with a corresponding message (in Portuguese) and one space between the two points and the value. The value calculated must be presented with 3 digits after the decimal point.

Input Samples Output Samples

3.0 4.0 5.2

TRIANGULO: 7.800
CIRCULO: 84.949
TRAPEZIO: 18.200
QUADRADO: 16.000
RETANGULO: 12.000

 

12.7 10.4 15.2

TRIANGULO: 96.520
CIRCULO: 725.833
TRAPEZIO: 175.560
QUADRADO: 108.160
RETANGULO: 132.080

 

Code Examples

#1 Code Example with C Programming

Code - C Programming


#include <stdio.h>

int main()
{
 double a, b, c;

 scanf("%lf %lf %lf", &a, &b, &c);

 printf("TRIANGULO: %.3lf\n", (a * c) / 2);
 printf("CIRCULO: %.3lf\n", c * c * 3.14159);
 printf("TRAPEZIO: %.3lf\n", ((a + b) / 2) * c);
 printf("QUADRADO: %.3lf\n", b * b);
 printf("RETANGULO: %.3lf\n", a * b);

 return 0;
}
Copy The Code & Try With Live Editor

Input

x
+
cmd
3.0 4.0 5.2

Output

x
+
cmd
TRIANGULO: 7.800 CIRCULO: 84.949 TRAPEZIO: 18.200 QUADRADO: 16.000 RETANGULO: 12.000

#2 Code Example with C Programming

Code - C Programming


#include <stdio.h>
#define pi 3.14159
int main ()
{
    float a,b,c;
    while (scanf("%f %f %f",&a,&b,&c) != EOF)
    {
 
        printf ("TRIANGULO: %.3f\n",.5*(a*c));
        printf ("CIRCULO: %.3f\n",pi*(c*c));
        printf ("TRAPEZIO: %.3f\n",.5*(a+b)*c);
        printf ("QUADRADO: %.3f\n",b*b);
        printf ("RETANGULO: %.3f\n",a*b);
 
    }
    return 0;
 
}
Copy The Code & Try With Live Editor

Input

x
+
cmd
3.0 4.0 5.2

Output

x
+
cmd
TRIANGULO: 7.800 CIRCULO: 84.949 TRAPEZIO: 18.200 QUADRADO: 16.000 RETANGULO: 12.000

#3 Code Example with C++ Programming

Code - C++ Programming




#include <cstdio>

int main()
{
 double a, b, c;

 scanf("%lf", &a);
 scanf("%lf", &b);
 scanf("%lf", &c);

 printf("TRIANGULO: %.3lf\n", (a * c) / 2);
 printf("CIRCULO: %.3lf\n", c * c * 3.14159);
 printf("TRAPEZIO: %.3lf\n", ((a + b) / 2) * c);
 printf("QUADRADO: %.3lf\n", b * b);
 printf("RETANGULO: %.3lf\n", a * b);

 return 0;
}


Copy The Code & Try With Live Editor

Input

x
+
cmd
12.7 10.4 15.2

Output

x
+
cmd
TRIANGULO: 96.520 CIRCULO: 725.833 TRAPEZIO: 175.560 QUADRADO: 108.160 RETANGULO: 132.080

#4 Code Example with Java Programming

Code - Java Programming


import java.util.Scanner;

public class Main {

 public static void main(String[] args) {
  double a, b, c;

  Scanner sc = new Scanner(System.in);
  a = sc.nextDouble();
  b = sc.nextDouble();
  c = sc.nextDouble();

  System.out.printf("TRIANGULO: %.3f\n", (a * c) / 2);
  System.out.printf("CIRCULO: %.3f\n", c * c * 3.14159);
  System.out.printf("TRAPEZIO: %.3f\n", ((a + b) / 2) * c);
  System.out.printf("QUADRADO: %.3f\n", b * b);
  System.out.printf("RETANGULO: %.3f\n", a * b);

 }

}
Copy The Code & Try With Live Editor

Input

x
+
cmd
12.7 10.4 15.2

Output

x
+
cmd
TRIANGULO: 96.520 CIRCULO: 725.833 TRAPEZIO: 175.560 QUADRADO: 108.160 RETANGULO: 132.080

#5 Code Example with Python Programming

Code - Python Programming


valor = input().split(" ")

a, b, c = valor
pi = 3.14159

triangulo = (float(a) * float(c))/2
circulo = pi * (float(c)* float(c))
trapezio = float(c) *(float(a) + float(b)) / 2
quadrado = float(b) * float(b)
retangulo = float(a) * float(b)


print("TRIANGULO: %0.3f\nCIRCULO: %0.3f\nTRAPEZIO: %0.3f\nQUADRADO: %0.3f\nRETANGULO: %0.3f" % (triangulo, circulo, trapezio, quadrado, retangulo))


Copy The Code & Try With Live Editor

Input

x
+
cmd
3.0 4.0 5.2

Output

x
+
cmd
TRIANGULO: 7.800 CIRCULO: 84.949 TRAPEZIO: 18.200 QUADRADO: 16.000 RETANGULO: 12.000
Advertisements

Demonstration


Previous
#1011 Beecrowd Online Judge Solution 1011 Sphere Solution in C, C++, Java, Python and C#
Next
#1014 Beecrowd Online Judge Solution 1014 Consumption Solution in C, C++, Java, Python and C#