Algorithm


Problem Name: beecrowd | 3214

Problem Link: https://www.beecrowd.com.br/judge/en/problems/view/3214

Soda Surpler

 

By Andreas Björklund FI Finland

Timelimit: 1

Tim is an absolutely obsessive soda drinker, he simply cannot get enough. Most annoyingly though, he almost never has any money, so his only obvious legal way to obtain more soda is to take the money he gets when he recycles empty soda bottles to buy new ones. In addition to the empty bottles resulting from his own consumption he sometimes find empty bottles in the street. One day he was extra thirsty, so he actually drank sodas until he couldn’t afford a new one.

 

Input

 

Three non-negative integers E, F, C, where E < 1000 equals the number of empty soda bottles in Tim’s possession at the start of the day, F < 1000 the number of empty soda bottles found during the day, and 1 < C < 2000 the number of empty bottles required to buy a new soda.

 

Output

 

How many sodas did Tim drink on his extra thirsty day?

 

 

 

Input Samples Output Samples

9 0 3

4

 

 

 

5 5 2

9

 

Code Examples

#1 Code Example with Javascript Programming

Code - Javascript Programming


var input = require('fs').readFileSync('/dev/stdin', 'utf8');
var lines = input.split('\n');

const pegarValores = (line) => line.split(" ").map(a => Number(a));

let [e, f, c] = pegarValores(lines.shift())
let total = 0;
e += f;
while (e >= c) {
    total++;
    e -= c;
    e++;
}
console.log(total);
Copy The Code & Try With Live Editor

Input

x
+
cmd
9 0 3

Output

x
+
cmd
4
Advertisements

Demonstration


Previous
#3209 Beecrowd Online Judge Solution 3209 Electrical Outlets Solution in C, C++, Java, Js and Python
Next
#3224 Beecrowd Online Judge Solution 3224 Aaah! Solution in C, C++, Java, Js and Python