Algorithm
Problem Name: beecrowd | 1142
Problem Link: https://www.beecrowd.com.br/judge/en/problems/view/1142
PUM
Adapted by Neilor Tonin, URI Brazil
Write a program that reads an integer N. This N is the number of output lines printed by this program.
Input
The input file contains an integer N.
Output
Print the output according to the given example.
Input Sample | Output Sample |
7 |
1 2 3 PUM |
Code Examples
#1 Code Example with C++ Programming
Code -
C++ Programming
#include <bits/stdc++.h>
using namespace std;
int main(){
int num;
cin >> num;
int count = 0;
for (int i = 1; i < = num * 4; i++){
if (count == 3){
cout << "PUM" << endl;
count = 0;
continue;
}
cout << i << " ";
count += 1;
}
return 0;
}
Copy The Code &
Try With Live Editor
Input
Output
#2 Code Example with Java Programming
Code -
Java Programming
import java.io.IOException;
import java.util.Scanner;
public class Main{
public static void main(String[] args) throws IOException{
Scanner input = new Scanner(System.in);
int num = input.nextInt();
int count = 0;
for (int i = 1; i < = num * 4; i++){
if (count == 3){
System.out.println("PUM");
count = 0;
continue;
}
System.out.printf("%d ", i);
count += 1;
}
}
}
Copy The Code &
Try With Live Editor
Input
Output
#3 Code Example with Javascript Programming
Code -
Javascript Programming
var input = require('fs').readFileSync('/dev/stdin', 'utf8');
var lines = input.split('\n');
var num = parseInt(lines.shift());
var count = 0;
for (var i = 1; i < = num * 4; i++){
if (count === 3){
console.log("PUM");
count = 0;
continue;
}
process.stdout.write(i+ " ");
count += 1;
}
Copy The Code &
Try With Live Editor
Input
Output
#4 Code Example with Python Programming
Code -
Python Programming
num = int(input())
count = 0
for i in range(1, (num * 4) + 1):
if (count == 3):
print("PUM")
count = 0
continue
print(i, end=" ")
count += 1
Copy The Code &
Try With Live Editor
Input
Output