Algorithm


Problem Name: beecrowd | 1182

Problem Link: https://www.beecrowd.com.br/judge/en/problems/view/1182

Column in Array

 

By Neilor Tonin, URI Brazil

Timelimit: 1

Your job in this problem is to read a number that is a column of an array where an operation will be performed, an uppercase character, indicating the operation to be performed and all elements of a bidimentional array M[12][12]. Then, you have to calculate and print the sum or average of all elements within the green area according to the case. The following figure illustrates the case when is entered the number 5 to the array column, showing all elements that must be considered in the operation.


 

Input

 

The first line of the input contains a simple integer C (0 ≤ C ≤ 11) indicating the column to be considered in the operation. The second line of the input contains a single uppercase character T ('S' or 'M'), indicating the operation Sum or Average (Média in portuguese) to be performed with the elements of the array. Follow 144 floating-point numbers of the array.

 

Output

 

Print the calculated result (sum or average), with one digit after the decimal point.

 

 

 

Input Sample Output Sample

5
S
1.0
-3.5
2.5
4.1
...

12.6

Code Examples

#1 Code Example with C++ Programming

Code - C++ Programming


#include <bits/stdc++.h>
using namespace std;

int main()
{
    double a[12][12];
    int n;
    cin >> n;
    char c;
    cin >> c;
    double sum = 0;
    for(int i = 0 ; i  <  12; i++){
        for(int j = 0 ; j  <  12; j++){
            cin >> a[i][j];
            if(j == n) sum += a[i][j];
        }
    }
    if(c == 'S') printf("%.1f\n" , sum);
    else if(c == 'M') printf("%.1f\n" , sum/12);


    return 0;
}
Copy The Code & Try With Live Editor

Input

x
+
cmd
5 S 1.0 -3.5 2.5 4.1 ...

Output

x
+
cmd
12.6
Advertisements

Demonstration


Previous
#1181 Beecrowd Online Judge Solution 1181 Line in Array Solution in C++, Java, Js and Python
Next
#1183 Beecrowd Online Judge Solution 1183 Above the Main Diagonal Solution in C++, Java, Js and Python