Algorithm
Problem Name: beecrowd | 1143
Problem Link: https://www.beecrowd.com.br/judge/en/problems/view/1143
Squared and Cubic
Adapted by Neilor Tonin, URI Brazil
Write a program that reads an integer N (1 < N < 1000). This N is the number of output lines printed by this program.
Input
The input file contains an integer N.
Output
Print the output according to the given example.
Input Sample | Output Sample |
5 |
1 1 1 |
Code Examples
#1 Code Example with C++ Programming
Code -
C++ Programming
#include <bits/stdc++.h>
using namespace std;
int main(){
int num;
cin >> num;
for (int i = 1; i < = num; i++){
cout << i << " " << (i * i) << " " << (i * i * i) << endl;
}
return 0;
}
Copy The Code &
Try With Live Editor
Input
Output
#2 Code Example with Java Programming
Code -
Java Programming
import java.io.IOException;
import java.util.Scanner;
public class Main{
public static void main(String[] args) throws IOException{
Scanner input = new Scanner(System.in);
int num = input.nextInt();
for (int i = 1; i < = num; i++){
System.out.printf("%d %d %d\n", i, (i * i), (i * i * i));
}
}
}
Copy The Code &
Try With Live Editor
Input
Output
#3 Code Example with Javascript Programming
Code -
Javascript Programming
var input = require('fs').readFileSync('/dev/stdin', 'utf8');
var lines = input.split('\n');
var num = parseInt(lines.shift());
for (var i = 1; i < = num; i++){
console.log(i +" "+ (i * i) +" "+ (i * i * i));
}
Copy The Code &
Try With Live Editor
Input
Output
#4 Code Example with Python Programming
Code -
Python Programming
num = int(input())
for i in range(1, num+1):
print(f"{i} {i * i} {i * i * i}")
Copy The Code &
Try With Live Editor
Input
Output