Algorithm


Problem Name: beecrowd | 1143

Problem Link: https://www.beecrowd.com.br/judge/en/problems/view/1143

Squared and Cubic

Adapted by Neilor Tonin, URI Brazil

Timelimit: 1

 

Write a program that reads an integer N (1 < N < 1000). This N is the number of output lines printed by this program.

 

Input

 

The input file contains an integer N.

 

Output

 

Print the output according to the given example.

 

 

 

Input Sample Output Sample

5

1 1 1
2 4 8
3 9 27
4 16 64
5 25 125

 

Code Examples

#1 Code Example with C++ Programming

Code - C++ Programming


#include <bits/stdc++.h>

using namespace std;

int main(){
    int num;
    cin >> num;
    for (int i = 1; i  < = num; i++){
        cout << i << " " << (i * i) << " " << (i * i * i) << endl;
    }
    return 0;
}
Copy The Code & Try With Live Editor

Input

x
+
cmd
5

Output

x
+
cmd
1 1 1 2 4 8 3 9 27 4 16 64 5 25 125

#2 Code Example with Java Programming

Code - Java Programming


import java.io.IOException;
import java.util.Scanner;

public class Main{
    public static void main(String[] args) throws IOException{
        Scanner input = new Scanner(System.in);
        int num = input.nextInt();
        for (int i = 1; i  < = num; i++){
            System.out.printf("%d %d %d\n", i, (i * i), (i * i * i));
        }
    }
}
Copy The Code & Try With Live Editor

Input

x
+
cmd
5

Output

x
+
cmd
1 1 1 2 4 8 3 9 27 4 16 64 5 25 125

#3 Code Example with Javascript Programming

Code - Javascript Programming


var input = require('fs').readFileSync('/dev/stdin', 'utf8');
var lines = input.split('\n');

var num = parseInt(lines.shift());

for (var i = 1; i  < = num; i++){
    console.log(i +" "+ (i * i) +" "+ (i * i * i));
}
Copy The Code & Try With Live Editor

Input

x
+
cmd
5

Output

x
+
cmd
1 1 1 2 4 8 3 9 27 4 16 64 5 25 125

#4 Code Example with Python Programming

Code - Python Programming


num = int(input())

for i in range(1, num+1):
    print(f"{i} {i * i} {i * i * i}")
Copy The Code & Try With Live Editor

Input

x
+
cmd
5

Output

x
+
cmd
1 1 1 2 4 8 3 9 27 4 16 64 5 25 125
Advertisements

Demonstration


Previous
#1142 Beecrowd Online Judge Solution 1142 PUM Solution in C++, Java, Js and Python
Next
#1144 Beecrowd Online Judge Solution 1144 Logical Sequence Solution in C++, Java, Js and Python