Algorithm


Problem Name: 2 AD-HOC - beecrowd | 1680

Problem Link: https://www.beecrowd.com.br/judge/en/problems/view/1680

Edge

 

Local Contest, University of Ulm DE Germany

Timelimit: 1

For products that are wrapped in small packings it is necessary that the sheet of paper containing the directions for use is folded until its size becomes small enough. We assume that a sheet of paper is rectangular and only folded along lines parallel to its initially shorter edge. The act of folding along such a line, however, can be performed in two directions: either the surface on the top of the sheet is brought together, or the surface on its bottom. In both cases the two parts of the rectangle that are separated by the folding line are laid together neatly and we ignore any differences in thickness of the resulting folded sheet.

After several such folding steps have been performed we may unfold the sheet again and take a look at its longer edge holding the sheet so that it appears as a one-dimensional curve, actually a concatenation of line segments. If we move along this curve in a fixed direction we can classify every place where the sheet was folded as either type A meaning a clockwise turn or type V meaning a counter-clockwise turn. Given such a sequence of classifications, produce a drawing of the longer edge of the sheet assuming 90 degree turns at equidistant places.

 

Input

 

The input contains several test cases, each on a separate line. Each line contains a nonempty string of characters A and V describing the longer edge of the sheet. You may assume that the length of the string is less than 200. The input file terminates immediately after the last test case.

 

Output

 

For each test case generate a PostScript drawing of the edge with commands placed on separate lines. Start every drawing at the coordinates (300,420) with the command "300 420 moveto". The first turn occurs at (310,420) using the command "310 420 lineto". Continue with clockwise or counter-clockwise turns according to the input string, using a sequence of "x y lineto" commands with the appropriate coordinates. The turning points are separated at a distance of 10 units. Do not forget the end point of the edge and finish each test case by the commands stroke and showpage.

You may display such drawings with the gv PostScript interpreter, optionally after a conversion using the ps2ps utility.

 

 

 

Sample Input Sample Output

V
AVV

300 420 moveto
310 420 lineto
310 430 lineto
stroke
showpage
300 420 moveto
310 420 lineto
310 410 lineto
320 410 lineto
320 420 lineto
stroke
showpage

 

Code Examples

#1 Code Example with C++ Programming

Code - C++ Programming


#include <bits/stdc++.h>

using namespace std;
int main ()
{
	string s1;
	int x;
	int y;
	while(getline(cin,s1))
	{
		cout << "300 420 moveto\n310 420 lineto\n";
		x = 310;
		y = 420;
		for (int i = 0 ; i  <  s1.size(); i++)
		{
			if (i == 0)
			{
				if (s1[i] == 'V') y+=10;
				else y-=10;
			}
			else
			{
				if (s1[i] == 'V')
				{
					if (s1[i-1] == 'A')
					{
						x+=10;
					}
					else
					{
						y+=10;
					}
				}
				else
				{
					if (s1[i-1] == 'A')
					{
						y-=10;
					}
					else
					{
						x-=10;
					}
				}
			}
			cout << x << " " << y << " lineto\n";
		}
		cout << "stroke\nshowpage\n";
	}
}
Copy The Code & Try With Live Editor

Input

x
+
cmd
V
AVV

Output

x
+
cmd
300 420 moveto
310 420 lineto
310 430 lineto
stroke
showpage
300 420 moveto
310 420 lineto
310 410 lineto
320 410 lineto
320 420 lineto
stroke
showpage
Advertisements

Demonstration


Previous
#1676 Beecrowd Online Judge Solution 1676 Assistance Required Solution in C, C++, Java, Js and Python
Next
#1708 Beecrowd Online Judge Solution 1708 Lap Solution in C, C++, Java, Js and Python