Algorithm


Problem Name: URI Online Judge | 2234

Problem Link: https://www.beecrowd.com.br/judge/en/problems/view/2234

Hot Dogs

 

By Maratona de Programação SBC BR Brazil

Timelimit: 1

In 2012 it was achieved a new world record in the famous Competition Hot Dogs Nathan: the champion, Joey Chestnut devoured 68 hot dogs in ten minutes, an increase amazing compared to 62 sandwiches devoured by the same Chestnut in 2011.

Nathan's Famous Corporation restaurant, located in Brooklyn, NY, is responsible for the competition. They produce delicious hot dogs, world famous, but when it comes math is they are not as good. They wish to be listed in the Guinness Book of Records, but they should fill out a form describing the basic facts of the competition. In particular, they must inform the average number of hot dogs consumed by participants during the competition.

You can help them? They promised to pay it with one of their tasty hot dogs. Given the total of hot dogs consumed and the total of participants in the competition, you should write a program to determine the average number of hot dogs consumed by participants.

 

Input

 

The input consists of a single line containing two integers H and P (1 ≤ H, P ≤ 1000) indicating respectively the total number of consumed hot dogs and the total number of participants in the competition.

 

Output

 

Your program should produce a single line with a rational number representing the average hot dogs consumed by the participants. The result should be written as a rational number with exactly two digits after the decimal point, rounded if necessary.

 

 

 

Input Examples Output Examples

10 90

0.11

 

 

 

840 11

76.36

 

 

 

1 50

0.02

 

 

 

34 1000

0.03

 

 

 

35 1000

0.04

 

Code Examples

#1 Code Example with C Programming

Code - C Programming


#include <stdio.h>
 
int main() { 
    float H, P, media;

    scanf("%f %f", &H, &P);
	media = H / P;
    printf("%.2f\n", media);

    return 0;
}
Copy The Code & Try With Live Editor

Input

x
+
cmd
10 90

Output

x
+
cmd
0.11

#2 Code Example with C++ Programming

Code - C++ Programming


#include <iostream>

int main(){
    float hotd, partc;
    std::cin >> hotd >> partc;
    std::cout.precision(2);
    std::cout.setf(std::ios::fixed);
    std::cout << hotd/partc << std::endl;

    return 0;
}
Copy The Code & Try With Live Editor

Input

x
+
cmd
10 90

Output

x
+
cmd
0.11

#3 Code Example with Javascript Programming

Code - Javascript Programming


var input = require('fs').readFileSync('/dev/stdin', 'utf8');
var lines = input.split('\n');
const [ax, bc] = lines.shift().split(" ");

console.log(`${(ax / bc).toFixed(2)}`);

Copy The Code & Try With Live Editor

Input

x
+
cmd
10 90

Output

x
+
cmd
0.11

#4 Code Example with Python Programming

Code - Python Programming


valores = input()
a,b = valores.split(" ")
result= float(float(a)/float(b))
print("{0:.2f}". format(result))
Copy The Code & Try With Live Editor

Input

x
+
cmd
10 90

Output

x
+
cmd
0.11
Advertisements

Demonstration


Previous
#3224 Beecrowd Online Judge Solution 3224 Aaah! Solution in C, C++, Java, Js and Python
Next
#3241 Beecrowd Online Judge Solution 3241 Help a PhD Candidate Out! Solution in C, C++, Java, Js and Python