Algorithm


Problem Name: 2 AD-HOC - beecrowd | 1403

Problem Link: https://www.beecrowd.com.br/judge/en/problems/view/1403

Grandpa is Famous

 

By Ricardo Anido Brazil

Timelimit: 3

The whole family was excited by the news. Everyone knew grandpa had been an extremely good bridge player for decades, but when it was announced he would be in Guinness Book of World Records as the most successful bridge player ever, whow, that was astonishing!

The International Bridge Association (IBA) has maintained, for several years, a weekly ranking of the best players in the world. Considering that each appearance in a weekly ranking constitutes a point for the player, grandpa was nominated the best player ever because he got the highest number of points.

Having many friends who were also competing against him, grandpa is extremely curious to know which player(s) took the second place. He needs a program which, when given a list of weekly rankings, finds out which player(s) got the second place according to the number of points.

 

Input

 

The input contains several test cases. Players are identified by integers from 1 to 10000. The first line of a test case contains two integers N and M indicating respectively the number of rankings available (2 ≤ N ≤ 500) and the number of players in each ranking (2 ≤ M ≤ 500). Each of the next N lines contains the description of one weekly ranking. Each description is composed by a sequence of M integers, separated by a blank space, identifying the players who figured in that weekly ranking. You can assume that:

  • in each test case there is exactly one best player and at least one second best player,
  • each weekly ranking consist of M distinct player identifiers.

The end of input is indicated by N = M = 0.

 

Output

 

For each test case in the input your program must produce one line of output, containing the identification number of the player who is second best in number of appearances in the rankings. If there is a tie for second best, print the identification number of all second best players in increasing order. Each identification number produced must be followed by a blank space.

 

 

 

Sample Input Sample Output

4 5
20 33 25 32 99
32 86 99 25 10
20 99 10 33 86
19 33 74 99 32
3 6
2 34 67 36 79 93
100 38 21 76 91 85
32 23 85 31 88 1
0 0

32 33
1 2 21 23 31 32 34 36 38 67 76 79 88 91 93 100

 

Code Examples

#1 Code Example with C++ Programming

Code - C++ Programming


#include <bits/stdc++.h>
#define FOR(i, a, b) for (int i = a; i  < = b; ++i)
#define RFOR(i, b, a) for (int i = b; i >= a; --i)
#define REP(i, N) for (int i = 0; i  <  N; ++i)
#define REPIT(c, it) for (list::iterator it = c.begin(); it != c.end(); it++)
#define MAX 30
#define INF 0x3F3F3F3F
#define pb push_back
#define mp make_pair

using namespace std;

typedef long long int64;
typedef pair < int, int> ii;
typedef vector<int> vi;

int main()
{
    ios::sync_with_stdio(false);
    int m, n, x;
    while (cin >> m >> n && m + n) {
        unordered_map < int, int> grandpa;
        unordered_map<int, int>::iterator it;
        REP(i, m)
        {
            REP(j, n)
            {
                cin >> x;
                if (!grandpa.count(x))
                    grandpa.insert(mp(x, 1));
                else
                    grandpa[x]++;
            }
        }
        priority_queue < ii> resp;
        for (it = grandpa.begin(); it != grandpa.end(); ++it)
            resp.push(mp(it->second, -it->first));
        resp.pop();
        int maior = resp.top().first;
        while (!resp.empty() && resp.top().first == maior) {
            cout << -resp.top().second << " ";
            resp.pop();
        }
        cout << "\n";
    }
    return 0;
}
Copy The Code & Try With Live Editor

Input

x
+
cmd
4 5
20 33 25 32 99
32 86 99 25 10
20 99 10 33 86
19 33 74 99 32
3 6
2 34 67 36 79 93
100 38 21 76 91 85
32 23 85 31 88 1
0 0

Output

x
+
cmd
32 33
1 2 21 23 31 32 34 36 38 67 76 79 88 91 93 100
Advertisements

Demonstration


Previous
#1397 Beecrowd Online Judge Solution 1397 Game of The Greatest Solution in C, C++, Java, Js and Python
Next
#1407 Beecrowd Online Judge Solution 1407 Weekend Lottery Solution in C, C++, Java, Js and Python