Algorithm


Problem Name: beecrowd | 1046
Problem Link: https://www.beecrowd.com.br/judge/en/problems/view/1046

Game Time

Adapted by Neilor Tonin, URI Brazil

Timelimit: 1

Read the start time and end time of a game, in hours. Then calculate the duration of the game, knowing that the game can begin in a day and finish in another day, with a maximum duration of 24 hours. The message must be printed in portuguese “O JOGO DUROU X HORA(S)” that means “THE GAME LASTED X HOUR(S)”

Input

Two integer numbers representing the start and end time of a game.

Output 

Print the duration of the game as in the sample output.

Input Sample Output Sample

16 2

O JOGO DUROU 10 HORA(S)

 

0 0

O JOGO DUROU 24 HORA(S)

 

2 16

O JOGO DUROU 14 HORA(S)

Code Examples

#1 Code Example with C Programming

Code - C Programming



#include <studio.h>
int main()

{
    int strtTm, endTm, durationTm;

    scanf("%d %d", &strtTm, &endTm);

    durationTm = endTm - strtTm;

    if (durationTm  <  0)
    {
        durationTm = 24 + (endTm - strtTm);
    }
    if (strtTm == endTm)
    {
        printf("O JOGO DUROU 24 HORA(S)n");
    }
    else printf("O JOGO DUROU %d HORA(S)n", durationTm);

    return 0;

}
Copy The Code & Try With Live Editor

Input

x
+
cmd
16 2

Output

x
+
cmd
O JOGO DUROU 10 HORA(S)

#2 Code Example with C++ Programming

Code - C++ Programming



#include <iostream>
using namespace std;

int main()
{
    int i, f;
    int ctr = 0;

    cin >> i >> f;

    if(i == f){
        cout << "O JOGO DUROU 24 HORA(S)" << endl;
        return 0;
    }
    while(i != f)
    {
        ctr++;
        i++;
        if(i == 25)
        i = 1;
    }

    cout << "O JOGO DUROU " << ctr <<  " HORA(S)" << endl;

    return 0;
}
Copy The Code & Try With Live Editor

Input

x
+
cmd
0 0

Output

x
+
cmd
O JOGO DUROU 24 HORA(S)

#3 Code Example with Java Programming

Code - Java Programming



import java.util.Scanner;


public class URI_1046 {
    public static void main(String[] args) {

        int strtTm, endTm, durationTm;

        Scanner sc = new Scanner(System.in);
        strtTm = sc.nextInt();
        endTm = sc.nextInt();

        durationTm = endTm - strtTm;

        if (durationTm  <  0)
        {
            durationTm = 24 + (endTm - strtTm);
        }

        if (strtTm == endTm)
        {
            System.out.printf("O JOGO DUROU 24 HORA(S)n");
        }

        else System.out.printf("O JOGO DUROU %d HORA(S)n", durationTm);

    }
}
Copy The Code & Try With Live Editor

Input

x
+
cmd
2 16

Output

x
+
cmd
O JOGO DUROU 14 HORA(S)

#4 Code Example with Python Programming

Code - Python Programming



a,b=list(map(int,input().split()))
if(a<b):
    time=b-a
else:
    time=b+24-a
print(f"O JOGO DUROU {time} HORA(S)">
Copy The Code & Try With Live Editor

Input

x
+
cmd
2 16

Output

x
+
cmd
O JOGO DUROU 14 HORA(S)
Advertisements

Demonstration


Previous
#1045 Beecrowd Online Judge Solution 1045 Triangle Types- Solution in C, C++, Java, Python and C#
Next
#1047 Beecrowd Online Judge Solution 1047 Game Time with Minutes- Solution in C, C++, Java, Python and C#