Algorithm
Consumption
Adapted by Neilor Tonin, URI Brazil
Calculate a car's average consumption being provided the total distance traveled (in Km) and the spent fuel total (in liters).
Input
The input file contains two values: one integer value X representing the total distance (in Km) and the second one is a floating point number Y representing the spent fuel total, with a digit after the decimal point.
Output
Present a value that represents the average consumption of a car with 3 digits after the decimal point, followed by the message "km/l".
Input Sample | Output Sample |
500 |
14.286 km/l |
2254 |
18.119 km/l |
4554 |
9.802 km/l |
Code Examples
#1 Code Example with C Programming
Code -
C Programming
#include <stdio.h>
int main()
{
double a, b;
scanf("%lf %lf", &a, &b);
printf("%.3lf km/l\n", a / b);
return 0;
}
Copy The Code &
Try With Live Editor
Input
35.0
Output
#2 Code Example with C++ Programming
Code -
C++ Programming
#include <cstdio>
int main()
{
double a;
double b;
scanf("%lf", &a);
scanf("%lf", &b);
printf("%.3lf km/l\n", a / b);
return 0;
}
Copy The Code &
Try With Live Editor
Input
124.4
Output
#3 Code Example with Java Programming
Code -
Java Programming
import java.util.Scanner;
public class Main {
public static void main(String[] args) {
double a, b;
Scanner sc = new Scanner(System.in);
a = sc.nextDouble();
b = sc.nextDouble();
System.out.printf("%.3f km/l\n", a / b);
}
}
Copy The Code &
Try With Live Editor
Input
464.6
Output
#4 Code Example with Python Programming
Code -
Python Programming
distancia = int(input())
combustivel = float(input())
consumo = distancia / combustivel
print("%0.3f km/l" %consumo)
Copy The Code &
Try With Live Editor
Input
35.0
Output
#5 Code Example with C# Programming
Code -
C# Programming
printf
km/l\n", a / b
Copy The Code &
Try With Live Editor
Input
35.0
Output